SDK3.0 Files/Tutorials werken niet op SDK 3.2?!?

SDK3.0 Files/Tutorials werken niet op SDK 3.2?!? discussie in Ontwikkelen voor iOS forum; ( verdwijnt na registratie ) Beste Mensen, Zins een aantal weken ben ik geintereseerd geraakt in het maken van apps in Iphone SDK , zodoende hou ik me bezig met ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > Development > Ontwikkelen voor iOS
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen
  #1  
Oud 3 September 2010, 08:31
» iPhone 5 16GB (Zwart) [FW: 7.0.3]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 16GB (Zwart) [FW: 4.3.4]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 23 December 2009
Berichten: 50
Standaard SDK3.0 Files/Tutorials werken niet op SDK 3.2?!?

Beste Mensen,

Zins een aantal weken ben ik geintereseerd geraakt in het maken van apps in Iphone SDK, zodoende hou ik me bezig met met volgen van tutorials. Echter heb ik nu het volgende al een paar keer meegemaakt: Als ik de juiste stappen van een uitleg/tutorial correct uitvoer en deze wil compilen/builden geeft hij de melding:" no file or folder found with the name: iphone3.0 "
Komt deze melding door het gebruiken van een nieuwere SDK versie aangezien ik dit probleem vaker heb gehad?
Wat kan je hier aan doen?? Het lijkt me erg moeilijk steeds de nieuwste tutorials en source files te vinden.
Ik hoop dat iemand hier een oplossing voor heeft.
Uiteraard heb ik de nieuwste SDK versie.

Greetz,

Crow ;-)

Laatst gewijzigd door TheCrow; 3 September 2010 om 09:37.
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 3 September 2010, 10:01
sukk1e's schermafbeelding
» iPhone 4 32GB (Zwart) [FW: 5.0.1]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 27 April 2010
Berichten: 134
Standaard

Jij download waarschijnlijk de samples van de tutorials. De oudere xcode projects hebben natuurlijk aanstaan dat ze op de oude simulator gedraaid moeten worden.

Kwestie van de get info bekijken van een project en BaseSDK, deploy target etc. aanpassen.
  #3  
Oud 3 September 2010, 10:02
» iPhone 5 16GB (Wit) [FW: 8.1.2]  [Jailbreak: Nee]
» iPad mini Wi-Fi 16GB (Zwart) [FW: 8.1.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 27 October 2008
Locatie: Amsterdam
Berichten: 174
Standaard

De nieuwste SDK voor iOS 4 heeft geen Base SDK 3.0 meer, je moet hier kiezen voor 4.0.
Dit doe je in je project settings.
Je kan er dan wel voor kiezen om je Deployment version op 3.0 te zetten.
  #4  
Oud 3 September 2010, 10:08
sukk1e's schermafbeelding
» iPhone 4 32GB (Zwart) [FW: 5.0.1]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 27 April 2010
Berichten: 134
Standaard

woei tux2k, ik was je voor!
  #5  
Oud 3 September 2010, 11:33
» iPhone 5 16GB (Wit) [FW: 8.1.2]  [Jailbreak: Nee]
» iPad mini Wi-Fi 16GB (Zwart) [FW: 8.1.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 27 October 2008
Locatie: Amsterdam
Berichten: 174
Standaard

Ik type niet zo snel
  #6  
Oud 3 September 2010, 11:50
» iPhone 5 16GB (Zwart) [FW: 7.0.3]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 16GB (Zwart) [FW: 4.3.4]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 23 December 2009
Berichten: 50
Standaard

Citaat:
Oorspronkelijk geplaatst door TUX2K Bekijk bericht
De nieuwste SDK voor iOS 4 heeft geen Base SDK 3.0 meer, je moet hier kiezen voor 4.0.
Dit doe je in je project settings.
Je kan er dan wel voor kiezen om je Deployment version op 3.0 te zetten.
Heren bedankt!!
Ik ga vanavond hier even naar kijken, ik hoop dat het lukt.
Als ik de deployment op 4.0 zet, is de app dan wel geschikt/werkzaam voor de nieuwste IOS4?
  #7  
Oud 3 September 2010, 11:53
» iPhone 5 16GB (Wit) [FW: 8.1.2]  [Jailbreak: Nee]
» iPad mini Wi-Fi 16GB (Zwart) [FW: 8.1.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 27 October 2008
Locatie: Amsterdam
Berichten: 174
Standaard

Ja, maar dus niet voor de iOS 3.*
  #8  
Oud 3 September 2010, 15:18
» iPhone 5 16GB (Zwart) [FW: 7.0.3]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 16GB (Zwart) [FW: 4.3.4]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 23 December 2009
Berichten: 50
Standaard

Citaat:
Oorspronkelijk geplaatst door TUX2K Bekijk bericht
Ja, maar dus niet voor de iOS 3.*
Oh dat is appart, dus je kan een app niet compatible maken voor zowel IOS 3.* en IoS 4.* ??
  #9  
Oud 3 September 2010, 15:50
» iPhone 4 16GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» iPad 1 Wi-Fi 16GB [FW: 4.3.3]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 24 November 2007
Berichten: 32
Stuur een bericht via MSN naar JNikoy Stuur een bericht via Skype™ naar JNikoy Send a message via twitter to JNikoy
Standaard

Jawel, daarom dus je deployment target op 3.0 zetten Hiermee geef je aan dat 3.0 de minimale versie van iOS is die nodig is om je app te kunnen draaien. Ook op devices met 4.0 zal je app dan dus gewoon werken.
  #10  
Oud 3 September 2010, 17:27
» iPhone 5 16GB (Wit) [FW: 8.1.2]  [Jailbreak: Nee]
» iPad mini Wi-Fi 16GB (Zwart) [FW: 8.1.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 27 October 2008
Locatie: Amsterdam
Berichten: 174
Standaard

Wat JNikoy zegt.

Denk er wel aan dat als je een methode aanroept die niet op iOS 3 aanwezig is je app dus crashed.
Dus je moet controleren of een methode aanwzig is.
Voorbeeld:
Code:
    if([[UIApplication sharedApplication] respondsToSelector:@selector(setStatusBarHidden:withAnimation:)]){
        // iOS 4.0
        [[UIApplication sharedApplication] setStatusBarHidden:NO withAnimation:UIStatusBarAnimationFade];
    } else {
        // iOS 3.*
        [[UIApplication sharedApplication] setStatusBarHidden:NO animated:NO];
    }
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
Website met goede (nederlandstalige) tutorials over het maken van Apps bengt Ontwikkelen voor iOS 3 20 October 2010 11:25
Tutorials JWVD Ontwikkelen voor iOS 12 30 September 2008 10:48
iPhone: Na aanpassen files wil iphone niet meer doorstarten Diegotjes Jailbreak 7 1 September 2008 16:59

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 10:01.