iCulture forum | iPhone, iPad,  iPod touch, Apple TV en iOS

iCulture forum | iPhone, iPad, iPod touch, Apple TV en iOS (https://forum.iculture.nl/)
-   Ontwikkelen voor iOS (https://forum.iculture.nl/f133/development/f58/ontwikkelen-voor-ios/)
-   -   Welke versie sdk voor 3.1.2 (https://forum.iculture.nl/f133/development/f58/ontwikkelen-voor-ios/73281-welke-versie-sdk-voor-3-1-2-a.html)

sentmen 28-09-10 11:34

Welke versie sdk voor 3.1.2
 
Hallo,

Ik wil voor mijn eigen iPhone een app maken. Ik heb de nieuwste sdk gedownload, maar dan moet ik mijn iPhone naar 4.0 updaten waar ik geen zin aan heb (ook om de reden dat dat moeilijk gaat met jailbreaken) en ik heb een oudere Mac met OSX 10.5 erop. Dus ik kan niet naar snow leopard. Weet iemand waar ik de sdk kan downloaden voor OSX 10.5 en iPhone Firmware 3.1.2?

Groeten Sentmen.

sukk1e 28-09-10 14:01

deploy target aanpassen.

Nieuwste SDK kan je niet eens installeren op 10.5
En ik zou ook niet willen werken met een SDK op een 10.5, die is al eeuwen oud.
als je lager dan 10.5.7 hebt zou ik niet gaan ontwikkelen tot je geupdate hebt.

Daar hoef je niet speciaal je telefoon voor te updaten.

sentmen 28-09-10 14:03

Waarom niet?

Whacko 28-09-10 14:04

Google.

heb laatst ook lopen zoeken, en zo moeilijk is ie niet te vinden.

Whacko 28-09-10 14:07

sorry 3.1.3 is de laatste versie die je nog kunt downloaden.
dan inderdaad je deployment target op 3.0 zetten, en je kan op je iPhone testen:

iPhone Software Development: Old versions of iPhone SDK

sukk1e 28-09-10 14:32

Wat whacko zegt

Citaat:

Oorspronkelijk geplaatst door sentmen (Bericht 572188)
Waarom niet?

Waarom wel? Waarom zou je een huis bouwen met hout als er steen tot je beschikking is?

wubbe 28-09-10 14:57

Ik ontwikkel ook in hout (XCode 3.2.2. met SDK 3.1.3).
Op deze manier krijg ik makkelijk voor elkaar dat mijn App werkt op een iPod Touch 1st generation, een iPod Touch 2nd generation, ieder type iPhone en een iPad.

De nieuwere versie van XCode heeft geen deployment target 3.1.3, of je moet gaan klooien met SDK's verplaatsen en zo. En daar heb ik geen zin in.

sentmen 28-09-10 15:35

Citaat:

Oorspronkelijk geplaatst door sukk1e (Bericht 572217)
Wat whacko zegt



Waarom wel? Waarom zou je een huis bouwen met hout als er steen tot je beschikking is?

Omdat ik namelijk geen 10.6 (Snow Leopard) op mijn mac heb en omdat ik geen apps wil gaan ontwikkelen voor de iOS 4.

sukk1e 28-09-10 15:39

Ik heb niks verplaatst enzo?

http://img442.imageshack.us/img442/5633/deploy.jpg

Sentmen:
10.6 hoeft ook niet perse, is wel handiger. Ik zei alleen dat ik niet zou ontwikkelen als je lager dan 10.5.7 hebt.
Ook in verband met samples etc. dat allemaal niet werkt omdat de code incompatible is.
En tutorials zijn allemaal anders uitgelegd.

p.s. wat is er zo lastig aan updaten? gewoon software update aanzetten en klaar?

sentmen 28-09-10 15:40

Welke versie is dat? En is die ook voor 10.5?

sukk1e 28-09-10 15:50

iPhone SDK 3.0 (Xcode 3.1.3) Leopard (10.5.7)
iOS Dev Center - Apple Developer

uit het lijstje van whacko

sentmen 29-09-10 09:04

Ik ga vanmiddag ermee bezig. Maar ik heb geprobeerd om die te downloaden, maar 3.1.3 kan ik niet downloaden vanaf die site. Dan kom ik in ios develop board of hoe dat ook heet zonder thema.

Iemand toevallig een andere site waar ik het goed kan downloaden?

sukk1e 29-09-10 12:03

Je kan op torrentsites zoeken maar de meeste zullen weinig tot geen seeders hebben.

Whacko 29-09-10 12:12

Citaat:

Oorspronkelijk geplaatst door sentmen (Bericht 572750)
Ik ga vanmiddag ermee bezig. Maar ik heb geprobeerd om die te downloaden, maar 3.1.3 kan ik niet downloaden vanaf die site. Dan kom ik in ios develop board of hoe dat ook heet zonder thema.

Iemand toevallig een andere site waar ik het goed kan downloaden?

als je ingelogd bent op de iPhone developer portal, dan werkt de link wel gewoon.

sentmen 29-09-10 12:48

Ik heb even een screenshotje gemaakt van wat ik krijg. Dit is wel op een 10.6 gemaakt, maar deze is niet van mij en inpreciepe kan ik hier ook nooit op. Dus ga a.u.b. niet zeggen dat ik het hier ook op kan doen want hier kan ik het niet op doen.

http://dutchsoulreapers.nl/mark/sdk1.png

TUX2K 29-09-10 13:51

Is de reden dat je niet naar 10.6 kan gaan mogelijk omdat je PowerPC ipv een Intel Mac hebt?
Want als dat zo is dan kan je enkel de SDk voor 3.0 draaien en niet de 3.1 versies.
Tevens zal je veel problem tegen komen op een PowerPC.

Als je file name van de download aanpast staan oude versies gewoon op de apple server.

Whacko 29-09-10 13:54

ik zei toch ook: Eerst inloggen op de developer portal (iOS Dev Center - Apple Developer), en daarna pas de link gebruiken. Je moet ingelogd zijn om te downloaden.

sentmen 29-09-10 16:01

Citaat:

Oorspronkelijk geplaatst door Whacko (Bericht 572918)
ik zei toch ook: Eerst inloggen op de developer portal (iOS Dev Center - Apple Developer), en daarna pas de link gebruiken. Je moet ingelogd zijn om te downloaden.

Ik ben al ingelogd. Ik wil ook wel een filmpje maken als je dat liever hebt;). Probeer anders zelf even:)

sentmen 29-09-10 16:03

Citaat:

Oorspronkelijk geplaatst door TUX2K (Bericht 572914)
Is de reden dat je niet naar 10.6 kan gaan mogelijk omdat je PowerPC ipv een Intel Mac hebt?
Want als dat zo is dan kan je enkel de SDk voor 3.0 draaien en niet de 3.1 versies.
Tevens zal je veel problem tegen komen op een PowerPC.

Als je file name van de download aanpast staan oude versies gewoon op de apple server.

Ik heb zelf een Intel. Maar ik heb de 10.6 dvd niet en ik ben zo al tevreden. En het is een computer voor school. En als ik er 10.6 op zet dan moet ik weer uren bezig gaan om alles te downloaden en erop te zetten en daar heb ik op dit moment geen zin in.

wubbe 29-09-10 16:06

Citaat:

Oorspronkelijk geplaatst door sentmen (Bericht 573052)
En als ik er 10.6 op zet dan moet ik weer uren bezig gaan om alles te downloaden en erop te zetten en daar heb ik op dit moment geen zin in.

Hee, het is wel een Apple hoor! Dvd er in en alles gaat verder vanzelf.


Alle tijden zijn GMT +2. Het is nu 14:36.