iCulture forum | iPhone, iPad,  iPod touch, Apple TV en iOS

iCulture forum | iPhone, iPad, iPod touch, Apple TV en iOS (https://forum.iculture.nl/)
-   iPhone algemeen (https://forum.iculture.nl/f28/iphone/f32/iphone-algemeen/)
-   -   iphone 4 downgrade van 6.1 naar 6.0.1 (https://forum.iculture.nl/f28/iphone/f32/iphone-algemeen/135091-iphone-4-downgrade-6-1-naar-6-0-1-a.html)

0ll1 12-02-13 11:16

iphone 4 downgrade van 6.1 naar 6.0.1
 
Hallo iedereen

Ik vroeg mij af of het mogelijk is om te downgraden van ios 6.1 naar 6.0.1 op een iphone 4. Ik heb de shsh blobs gesaved, gestitcht met zowel ifaith als snowbreeze, maar beiden geven diverse foutmeldingen wanneer ik deze probeer te herstellen via itunes (meestal error code 1600). De iphone stond in pwnd dfu mode en tinyumbrella's tss server stond aan.

Op welke manier kan ik dit probleem verhelpen en alsnog downgraden?

Mvg

FridgeNL 12-02-13 12:56

Weet niet of de huidige versie van redsn0w al IOS 6.1/6.1.1 ondersteund maar deze zou je kunnen proberen.

0ll1 12-02-13 18:33

Bedankt voor de reactie, ik heb dit al geprobeerd met de laatste versie (0.9.15b3), maar ie blijft altijd hangen op "uploading iBSS" en als ik de ipsw selecteer van 6.0.1, geeft ie de melding dat de ipsw niet herkend wordt. Ik veronderstel dus dat die versie nog niet de nieuwste firmware ondersteunt, nog eventjes afwachten dus.

dennie187 05-04-13 07:16

of gewoon 5.1.1 gebruiken als je daar de shsh van hebt :D
word wel tijd dat ze downgrade voor ios 6 ook mogelijk maken "beter als 3x voor ios 6 jailbreak progamma maken en of aan passen "

antoon100 05-04-13 08:54

Citaat:

Oorspronkelijk geplaatst door dennie187 (Bericht 889174)
word wel tijd dat ze downgrade voor ios 6 ook mogelijk maken "beter als 3x voor ios 6 jailbreak progamma maken en of aan passen "

En dat niet alleen voor de iPhone 4 vergeet de andere iDevices ook niet zoals de iPhone 4S, 5, iPad X kan altijd handig worden in toekomst.

Dat vind ik ook beter dan 3-4 JB op een jaar uitbrengen die toch iedere keer onmogelijk gemaakt worden bij bep. iOS update.

dennie187 05-04-13 08:56

Citaat:

Oorspronkelijk geplaatst door antoon100 (Bericht 889183)
En dat niet alleen voor de iPhone 4 vergeet de andere iDevices ook niet zoals de iPhone 4S, 5, iPad X kan altijd handig worden in toekomst.

Dat vind ik ook beter dan 3-4 JB op een jaar uitbrengen die toch iedere keer onmogelijk gemaakt worden bij bep. iOS update.

Helemaal mee eens !!!!👍

Guest-20180925190238 05-04-13 08:59

Citaat:

Oorspronkelijk geplaatst door dennie187 (Bericht 889184)
Helemaal mee eens !!!!👍

Dan ga de Devs toch helpen om een downgrade mogelijk te maken. Wat houdt je tegen? :rolleyes:

dennie187 05-04-13 09:05

Citaat:

Oorspronkelijk geplaatst door timosha (Bericht 889185)
Dan ga de Devs toch helpen om een downgrade mogelijk te maken. Wat houdt je tegen? :rolleyes:

Ben jij al aan helpen dan 😬

Guest-20180925190238 05-04-13 09:10

Citaat:

Oorspronkelijk geplaatst door dennie187 (Bericht 889186)
Ben jij al aan helpen dan ��

Nee, maar ik eis ook niet dat de Devs dat probleem onmiddellijk gaan oplossen :D

Voor de JB van iOS 6.1.3 heeft Apple een klein stokje gestoken. Voor het downgraden van iOS 6.x.x heeft Apple een hele dikke knuppel gestoken. Lees de blog van het iPhone Dev Team.

antoon100 05-04-13 09:33

Zie deze post uit The iPhone Wiki:

Citaat:

APTickets are the new type of SHSH blobs, used by iOS 5.0 and newer. The client (iBSS/LLB/iBoot/SROM) generates a random string (nonce), then iTunes and the device sends the request for blob signing and the server returns the data, just like the original SHSH protocol.
iOS 5+ iDevices gebruik maken van een nieuw type shsh blobs wat blijkbaar APtickets noemt.

staat hier toevallig ook niet:

Citaat:

A vulnerability found independently by iH8sn0w and the iPhone Dev Team allowed downgrading all A5 devices running 5.x with their saved APTickets by restoring the latest firmware- verifying APTicket with the iBSS or iBoot then restoring the hacked firmware without APTicket- then when the restore ends, the requisite firmware is restored. This method theoretically works with BBTickets, but such a baseband downgrade was never out.
Dus er is een methode dat theoretisch zou moeten werken staat hier.

Wat denken jullie hiervan?

dennie187 05-04-13 09:56

Citaat:

Oorspronkelijk geplaatst door timosha (Bericht 889187)
Nee, maar ik eis ook niet dat de Devs dat probleem onmiddellijk gaan oplossen :D

Voor de JB van iOS 6.1.3 heeft Apple een kleine stokje gestoken. Voor het downgraden van iOS 6.x.x heeft Apple een hele dikke knuppel gestoken. Lees de blog van het iPhone Dev Team.

Ik eis ook niks geef alleen een mening ... Jij geeft er nu een hele andere draai aan maar goed ..aangezien ik geen zin heb in discussie wens ik je een fijne dag 👍

Guest-20180925190238 05-04-13 09:57

Citaat:

Oorspronkelijk geplaatst door antoon100 (Bericht 889189)
Wat denken jullie hiervan?

Wat ik denk? Ik denk dat je beter eerst eens het hele verhaal van het iPhone Dev Team leest (en tracht te begrijpen):

Dev-Team Blog

Succes verder :)

antoon100 05-04-13 09:58

Citaat:

Oorspronkelijk geplaatst door dennie187 (Bericht 889191)
Ik eis ook niks geef alleen een mening ...

Ik ook, alleen probeer ik er meer te weten over te komen.

arjan95 05-04-13 10:30

Tenzij er ooit nog een BootROM exploit wordt gevonden, is de kans uiterst minimaal dat er ooit nog gedowngraded kan worden op apparaten met een A5 of een nieuwere processor.
De nieuwe "APtickets" worden willekeurig gemaakt en kunnen dus niet, zoals bij SHSH Blobs, worden opgeslagen en hergebruikt.

De reden dat de iPhone 4 / 3GS / iPod touch 4g toch gedowngraded kunnen worden is omdat zij het LimeRain exploit in de bootROM hebben. Daarmee kan deze beveiliging omzeilt worden.

antoon100 05-04-13 10:34

Dit vind ik interessante info,

Ok, dus we mogen het voor A5 of nieuwer zo goed als vergeten maar niet volledig uitsluiten.

En de toestellen die het wel kunnen door die LimeRain exploit klopt dit dat daar alvorens ooit een jailbreak op vereist was op het toestel?

Alvast op voorhand bedankt!

iNemesis 05-04-13 11:09

@antoon100. Dat er een bootrom exploit wordt gevonden is zeer onwaarschijnlijk.
Aangezien Geoh0t die bijna alle bootrom exploits op zijn naam heeft staan zich niet meer bemoeit met iDevices. Dus tip , als je op jailbreakable versie zit, blijf erop totdat een nieuwe jailbreak komt. RE restoren kan meestal ook nog wel met APtickets.

0ll1 08-05-13 11:12

kweet niet meer waar ik het ergens gelezen heb, op twitter geloof ik, dat een onbekende dev bijna in staat is om eender gelijk welke iphone, zowel 4, 4S als 5 te downgraden naar eender gelijk welk iOS via een nieuwe exploit... (de bron moet ik eens opzoeken)

Guest-20180925190238 08-05-13 11:13

Citaat:

Oorspronkelijk geplaatst door 0ll1 (Bericht 893935)
(de bron moet ik eens opzoeken)

Ja, zoek die bron maar eens op. Maar liefst geen JoeTjoep filmpjes :)

antoon100 08-05-13 18:50

Dat klopt het is p0sixninja die een bootrom exploit zou vinden (in zijn eentje), het zal ook hem zijn die de volgende jailbreak zal uitbrengen (iOS7) als de exploits niet gepatcht worden door Apple.

Indien de exploits gepatcht worden (zal het sowieso langer duren voor een JB dan bij lancering iOS 7) en vermoed ik einde van 2013 voor een nieuwe Jailbreak.

zie dit eens: Mogelijke Bootrom exploit A5/A5X/A6/A6X

Bubbly 08-05-13 19:13

Het ligt er maar aan. i0n1c geeft regelmatig exploits bloot, vooral als hij er persoonlijk geen geld mee kan verdienen. Gegarandeerd zitten er een paar tussen die jailbreak ontwikkelaars geheim hielden voor iOS 7.


Alle tijden zijn GMT +2. Het is nu 08:28.