Expired provisioning file, upgrade ipa nodig?

Expired provisioning file, upgrade ipa nodig? discussie in Ontwikkelen voor iOS forum; ( verdwijnt na registratie ) Ik heb 2 jaar geleden een adhoc app laten maken. De ipa file distribueerde ik naar een aantal ipads via testflight. De udids van deze ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > Development > Ontwikkelen voor iOS
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen
  #1  
Oud 5 February 2015, 06:01
» Ik heb geen iPhone  
» iPad 3 Wi-Fi 16GB (Zwart) [FW: 8.1.3]  [Jailbreak: Nee]
» Windows
 
Geregistreerd: 5 February 2015
Berichten: 1
Standaard Expired provisioning file, upgrade ipa nodig?

Ik heb 2 jaar geleden een adhoc app laten maken. De ipa file distribueerde ik naar een aantal ipads via testflight. De udids van deze ipads waren opgenomen.

Sinds kort werkt de app ineens niet meer. Als ik de .ipa file via testflight wil installeren krijg ik de melding "This build's provisioning profile has expired. Ask the developers to release a new build with an updated profile." Ook bij opnieuw uploaden van de .ipa file in testflight krijg ik een gelijksoortige melding.

Ik heb de appbuilder gevraagd om een nieuwe .ipa file. Hij geeft echter aan dat eerst een upgrade van de app nodig is. Een compile zou op ios8 plaatsvinden en daar zouden nu foutmeldingen uit voortkomen die eerst verholpen moeten worden. De app werkte voorheen wel op ios8.

Kan dit inderdaad het geval zijn en is er eventueel een mogelijkheid om buiten de appbuilder om de .ipa file toch weer werkend te krijgen? Appel developer account is aanwezig.
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 6 February 2015, 15:42
» iPhone 4 32GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» iPad 3 Wi-Fi 16GB (Zwart) [FW: 5.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 14 October 2008
Locatie: Haarlem
Berichten: 348
Standaard

  1. Inderdaad klopt het dat je profiel verlopen kan zijn. De App ontwikkelaar moet zijn distribution profile vernieuwen en een nieuwe IPA maken met dit vernieuwde profiel. Dan kun je weer twee jaar vooruit
  2. Een adhoc profiel is bedoeld voor beta testen, en niet voor regulier gebruik van een App. Vandaar dat hij maar beperkt geldig is. Om Apps te kunnen distribueren buiten de AppStore om is het (dure) Enterprise Programma in het leven geroepen. Maar ik kan me voorstellen dat dat iets te hoog gegrepen is. Je misbruikt het adhoc principe, maar goed.
  3. Waarom zou een compile op iOS8 moeten plaatsvinden? Je plaatst hem niet in de App Store. Misschien dat TestFlight dat vereist. Maar dan gebruik je TestFlight toch lekker niet? Gewoon een IPA distribueren op 'de oude manier' gaat toch ook?
__________________
Leon
[iPhone- en Java ontwikkelaar]
  #3  
Oud 18 February 2015, 09:25
» iPhone 5s 16GB (Goud) [FW: 7.1.2]  [Jailbreak: Nee]
» iPad 1 Wi-Fi 16GB [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 12 January 2009
Berichten: 484
Standaard

3. Een aanvulling hierop. Ik kan me best voorstellen dat de app voorheen werkte toen hij gecompiled was met een oude iOS SDK. De ontwikkelaar zal geupgrade hebben naar de nieuwste SDK en daar kunnen inderdaad fouten uit komen. Dat zal dan inderdaad eerst opgelost moeten worden.
__________________
Software Engineer
iPhone Developer
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 12:44.