Symbols not found

Symbols not found discussie in Ontwikkelen voor iOS forum; ( verdwijnt na registratie ) Hallo allemaal, ik ben bezig met een demon. Ik heb een exampeltje gedownload waar ik het een en ander wat wil mee uit proberen. Nu ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > Development > Ontwikkelen voor iOS
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen
  #1  
Oud 29 October 2010, 01:39
» iPhone 5 16GB (Zwart) [FW: 7.0.6]  [Jailbreak: Ja]
» iPad Air Wi-Fi + 4G 16GB (Spacegrijs) [FW: 7.0.6]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 25 October 2009
Locatie: Enschede
Berichten: 144
Stuur een bericht via MSN naar sentmen Stuur een bericht via Skype™ naar sentmen Send a message via twitter to sentmen
Standaard Symbols not found

Hallo allemaal,

ik ben bezig met een demon. Ik heb een exampeltje gedownload waar ik het een en ander wat wil mee uit proberen. Nu geeft hij een aantal errors. Ik schrijf ze even apart op omdat ik nu op mijn iphone zit.

Collect2: Id returned 1 exit status
symbol(s) not found
-[CAPowerManagement powerMessageRecieved:withArgument:] in CAPowerManagement.o
"_IOPowerChange", referenced from:
-[CAPowerManagement init] in CAPowerManagement.o
warning in /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS3.1.2.sdk/System/Library/Frameworks//IOKit.framework/IOKit, missing required architecture arm in (verder zie ik niet)

En daarna nog een paar fouten. Maar als ik op internet dat opzoek dan zegt hij dat je de framework mist, maar die heb ik erbij gedaan. Maar doe ik iets verkeert of is het exampeltje gewoon fout gescheven?

Alvast bedankt,
sentmen.
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 29 October 2010, 03:00
» iPhone 5s 16GB (Goud) [FW: 7.1.2]  [Jailbreak: Nee]
» iPad 1 Wi-Fi 16GB [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 12 January 2009
Berichten: 484
Standaard

Die melding krijg je inderdaad als je een Framework mist. Ik dacht eerst dat je misschien de Simulator versie toegevoegd had, maar in het path staat iPhoneOS.platform, dus dat is het niet.
Zit IOKit wel in 3.1.2? Als het iOS4 specifiek is, kan dat het zijn wat fout gaat.

Ik kan verder zo ook niet zien wat er mis gaat. Ik heb geen 3.x sdk meer, dus kan het niet proberen.
__________________
Software Engineer
iPhone Developer
  #3  
Oud 29 October 2010, 11:12
» iPhone 5 16GB (Zwart) [FW: 7.0.6]  [Jailbreak: Ja]
» iPad Air Wi-Fi + 4G 16GB (Spacegrijs) [FW: 7.0.6]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 25 October 2009
Locatie: Enschede
Berichten: 144
Stuur een bericht via MSN naar sentmen Stuur een bericht via Skype™ naar sentmen Send a message via twitter to sentmen
Standaard

Ok. Deze is gebaseerd op de 2.2.1 firmware maar hij werkt ook op de 3.1.2. Ik ben nog maar een beginner dus het kan best zijn dat ik iets fout doe hoor. Maar op internet heb ik gelezen dat dat zo moet. De iokit bestaat voor 3.1.2 denk ik niet, maar kan ik de iokit van 2.2.1 ook gebruiken?

Groeten sentmen.
  #4  
Oud 29 October 2010, 16:13
» iPhone 5s 16GB (Goud) [FW: 7.1.2]  [Jailbreak: Nee]
» iPad 1 Wi-Fi 16GB [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 12 January 2009
Berichten: 484
Standaard

Als je de 2.2.1 SDK hebt geinstalleerd, en specifiek build voor 2.2.1 dan wel, volgens mij kan je hem niet gebruiken als je voor 3.x build.
Maar dat maakt niet uit want een 2.x app draait geloof ik gewoon op 3.x
  #5  
Oud 29 October 2010, 17:00
» iPhone 5 16GB (Zwart) [FW: 7.0.6]  [Jailbreak: Ja]
» iPad Air Wi-Fi + 4G 16GB (Spacegrijs) [FW: 7.0.6]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 25 October 2009
Locatie: Enschede
Berichten: 144
Stuur een bericht via MSN naar sentmen Stuur een bericht via Skype™ naar sentmen Send a message via twitter to sentmen
Standaard

Hoe installeer ik dan de 2.2.1 sdk?

Groeten Sentmen.

#EDIT Niet goed gelezen. Sorry.

Laatst gewijzigd door sentmen; 29 October 2010 om 22:58.
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
No camera was found melding McMiles iPhone algemeen 5 1 June 2010 17:37
NES: No ROMs Found Jermainee Jailbreak apps en thema's 2 30 May 2010 12:33
HTTP/1.1 404 Not Found XanderSnelder Archief 1 23 December 2009 22:59
12 Bugs Found In iPhone OS 3.0 bicabo Chat en geruchten 2 26 June 2009 09:40
sim not found vdbroekw iPhone algemeen 2 14 May 2008 10:24

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 12:50.