IOS5 apps op 10.5.8

IOS5 apps op 10.5.8 discussie in Ontwikkelen voor iOS forum; ( verdwijnt na registratie ) Hallo, Ik vroeg mij af of het mogelijk is om apps voor IOS5 te maken op een mac met leopard 10.5.8. Mvg....



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > Development > Ontwikkelen voor iOS
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen
  #1  
Oud 3 November 2011, 21:08
» iPhone 3GS 16GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Windows
 
Geregistreerd: 17 October 2011
Berichten: 9
Standaard IOS5 apps op 10.5.8

Hallo,

Ik vroeg mij af of het mogelijk is om apps voor IOS5 te maken op een mac met leopard 10.5.8.

Mvg.
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 3 November 2011, 22:54
» iPhone 4S 16GB (Wit) [FW: 5.0.1]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 64GB (Zwart) [FW: 5.0.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 30 June 2009
Berichten: 137
Send a message via twitter to Jeroen0704
Standaard

Nee, dat is niet mogelijk als ik naar de Xcode downloads kijk. Je hebt namelijk Xcode 4.2 nodig om apps voor iOS 5 te maken en die is allen beschikbaar voor Snow Leopard en Lion.
  #3  
Oud 3 November 2011, 23:08
» iPhone 3GS 16GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Windows
 
Geregistreerd: 17 October 2011
Berichten: 9
Standaard

Is het dan wel mogelijk om een app die gemaakt is voor een lagere IOS of te spelen op IOS5?

(evt dmv een jailbreak)
  #4  
Oud 3 November 2011, 23:09
» iPhone 4S 16GB (Wit) [FW: 5.0.1]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 64GB (Zwart) [FW: 5.0.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 30 June 2009
Berichten: 137
Send a message via twitter to Jeroen0704
Standaard

Ja, dat is mogelijk en zelfs zonder jailbreak.
  #5  
Oud 3 November 2011, 23:11
» iPhone 3GS 16GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Windows
 
Geregistreerd: 17 October 2011
Berichten: 9
Standaard

Oke, bedankt voor je hulp!

Maar wat is dan eigenlijk het voordeel om met een nieuwe versie te werken?
  #6  
Oud 3 November 2011, 23:13
» iPhone 4S 16GB (Wit) [FW: 5.0.1]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 64GB (Zwart) [FW: 5.0.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 30 June 2009
Berichten: 137
Send a message via twitter to Jeroen0704
Standaard

In een nieuwere versie zitten natuurlijk nieuwe functionaliteiten, die in de oudere versies niet zitten. in iOS 5 zijn dat bijvoorbeeld iCloud en het Twitter framework.

Laatst gewijzigd door Jeroen0704; 3 November 2011 om 23:49.
  #7  
Oud 4 November 2011, 09:28
» iPhone 5s 16GB (Goud) [FW: 7.1.2]  [Jailbreak: Nee]
» iPad 1 Wi-Fi 16GB [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 12 January 2009
Berichten: 484
Standaard

Je kunt inderdaad een App bouwen met XCode3 en builden voor iOS4 ofzo. Alleen kun je dan niet debuggen, omdat XCode niet met je iPhone met iOS5 kan omgaan. Je moet de app dan handmatig via iTunes of iPhone Configuration Utility erop zetten. MITS je natuurlijk de juiste provisioning profiles hebt.
__________________
Software Engineer
iPhone Developer

Laatst gewijzigd door XIII; 4 November 2011 om 09:56. Reden: Opschonen: geen tips over iOS Developer Programma omzeilen aub
  #8  
Oud 5 November 2011, 09:17
» iPhone 3GS 16GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Windows
 
Geregistreerd: 17 October 2011
Berichten: 9
Standaard

Waarom ondersteunt xCode niet dat mijn iphone ios5 als test toestel wordt aanmeld? Terwijl **** toch iemand had gezegt dat apps altijd op horgere firmware's werken...

Het is trouwens xCode 3.1.4

Mvg
  #9  
Oud 5 November 2011, 11:28
» iPhone 4 32GB (Zwart) [FW: 5.1.1]  [Jailbreak: Nee]
» iPad 3 Wi-Fi 32GB (Zwart) [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 4 October 2010
Locatie: Breda
Berichten: 68
Standaard

Het antwoord op je vraag staat in de post van Whacko. Jouw versie van Xcode is te oud om met iOS 5 om te kunnen gaan. Je zult een device met iOS 4 (of waarschijnlijk zelfs 3) moeten gebruiken om te testen. De enige manier waarop je de app op een iOS 5 device krijgt is via iTunes of de iPhone Configuration Utility en een ad-hoc build.

Of, wat waarschijnlijk gemakkelijker is, upgrade je Mac naar Snow Leopard. Voorlopig draait Xcode 4 daar nog op (maar waarschijnlijk niet lang meer; het zou me niet verbazen als Lion binnenkort een vereiste wordt).
  #10  
Oud 5 November 2011, 12:03
XIII's schermafbeelding
iPhone(club) Guru
» iPhone X 256GB (Spacegrijs) [FW: 11.4]  [Jailbreak: Nee]
» iPad Pro 10,5 Wi-Fi + 4G 256GB (Spacegrijs) [FW: 11.4]  [Jailbreak: Nee]
» Windows
 
Geregistreerd: 1 July 2009
Berichten: 10.015
Standaard

Citaat:
Oorspronkelijk geplaatst door 11221122 Bekijk bericht
Waarom ondersteunt xCode niet dat mijn iphone ios5 als test toestel wordt aanmeld? Terwijl **** toch iemand had gezegt dat apps altijd op horgere firmware's werken...
Wat is volgens jou het logisch verband tussen die 2 zinnen?

Ik zie/snap het niet...
__________________
We are one, but we are not the same... Talk to each other!
  #11  
Oud 5 November 2011, 12:09
» iPhone 3GS 16GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Windows
 
Geregistreerd: 17 October 2011
Berichten: 9
Standaard

Ik moet toegeven, het staat er een beetje onhandig.

Wat ik probeerde te zeggen. Mij was verteld dat een app die bijvoorbeeld voor IOS3 ook op IOS4 werkt en ook op IOS5. Ik had dus een app gemaakt voor 3.1.4 maar xCode gaf aan dat mijn IOS5 device niet ondersteund werd. Wat dus een beetje tegenstrijdig was met het geen dat mij is verteld.. Maar ik heb het zeker verkeerd begrepen.
  #12  
Oud 8 November 2011, 13:26
» iPhone 5s 16GB (Goud) [FW: 7.1.2]  [Jailbreak: Nee]
» iPad 1 Wi-Fi 16GB [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 12 January 2009
Berichten: 484
Standaard

Nee dat is niet tegenstrijdig. De app werkt wel degelijk. Alleen moet je hem handmatig via itunes ofzo erop zetten. Het punt is, dat XCODE niet met de nieuwe IOS versie kan omgaan. Dit is gewoon zo gemaakt, zodat jij je SDK up to date houdt. wat in jouw geval dus niet gaat omdat je nog op leopard draait.
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
IOS5 iCloud restore, apps worden niet teruggezet eddzzz iCloud 2 17 November 2011 10:30
ios5 tinos iPhone algemeen 3 14 October 2011 17:00
Geen apps & muziek en ruimte meer na update ios5 dieterzLs Muziek, foto & video 9 13 October 2011 20:25
Werkt de iOs5 GM jailbreak ook op de iOs5 Final? benna Jailbreak 3 12 October 2011 19:38
iPhone 4 iOS5 Beta 1 naar iOS5 Beta 2 updaten probleem iOS5 iPhone algemeen 19 30 June 2011 15:18

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 20:35.