Mijn applicatie wilt niet laden

Mijn applicatie wilt niet laden discussie in Ontwikkelen voor iOS forum; ( verdwijnt na registratie ) Beste lezers, Ik heb denk mijn applicatie laten crashen. Ik krijg het laad scherm dat ik gemaakt heb wel te zien.. maar daarna sluit hij ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > Development > Ontwikkelen voor iOS
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen
  #1  
Oud 7 October 2010, 16:15
Zaankantertje75's schermafbeelding
» Ik heb geen iPhone  
» Mac OS X
 
Geregistreerd: 6 October 2010
Locatie: Zaandam
Berichten: 42
Send a message via twitter to Zaankantertje75
Unhappy Mijn applicatie wilt niet laden

Beste lezers,

Ik heb denk mijn applicatie laten crashen.

Ik krijg het laad scherm dat ik gemaakt heb wel te zien..

maar daarna sluit hij gelijk af.

wat kan dat zijn??

bram
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 7 October 2010, 18:28
» iPhone 5 16GB (Wit) [FW: 8.1.2]  [Jailbreak: Nee]
» iPad mini Wi-Fi 16GB (Zwart) [FW: 8.1.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 27 October 2008
Locatie: Amsterdam
Berichten: 174
Standaard

Ja dat weten wij ook niet, er zijn namelijk nog al wat mogelijkheden.
Maar wat zegt je debugger?
  #3  
Oud 7 October 2010, 20:05
Zaankantertje75's schermafbeelding
» Ik heb geen iPhone  
» Mac OS X
 
Geregistreerd: 6 October 2010
Locatie: Zaandam
Berichten: 42
Send a message via twitter to Zaankantertje75
Standaard

Citaat:
Oorspronkelijk geplaatst door TUX2K Bekijk bericht
Ja dat weten wij ook niet, er zijn namelijk nog al wat mogelijkheden.
Maar wat zegt je debugger?
ja sorry vergeten bij te zetten.

terminate called after throwing an instance of `NSException`
program received signal: "SIGABRT".
  #4  
Oud 7 October 2010, 20:27
» iPhone 5 16GB (Wit) [FW: 8.1.2]  [Jailbreak: Nee]
» iPad mini Wi-Fi 16GB (Zwart) [FW: 8.1.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 27 October 2008
Locatie: Amsterdam
Berichten: 174
Standaard

Daar kunnen we nog niks mee.
Gebruik XCode om te vertellen welke regel hij vast loopt en post je code waar het mis gaat.
  #5  
Oud 8 October 2010, 11:46
Zaankantertje75's schermafbeelding
» Ik heb geen iPhone  
» Mac OS X
 
Geregistreerd: 6 October 2010
Locatie: Zaandam
Berichten: 42
Send a message via twitter to Zaankantertje75
Standaard

Citaat:
Oorspronkelijk geplaatst door TUX2K Bekijk bericht
Daar kunnen we nog niks mee.
Gebruik XCode om te vertellen welke regel hij vast loopt en post je code waar het mis gaat.
Ik heb geen error in em exCode dat is het hem juist ik snat er nisk van..

Ik heb alleen bij @end een warning: Incomplete implementation of class 'FirstViewController'

en daar onder method for go forward didn;t found.

ik denk zelf dat ik iets fout heb gedaan in interface builder?

alvast bedankt
  #6  
Oud 8 October 2010, 11:56
» iPhone 5 16GB (Wit) [FW: 8.1.2]  [Jailbreak: Nee]
» iPad mini Wi-Fi 16GB (Zwart) [FW: 8.1.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 27 October 2008
Locatie: Amsterdam
Berichten: 174
Standaard

Oke, als je applicatie draait op je telefoon via de debugger in XCode dan kan je zien waar vast loopt.
In de balk in de source code scherm zit een dropdown lijstje, hier kan je op klikken en dan zie je de methode die worden aangeroepen, en dus ook die gene waar hij op vast loopt.

Je kom ook nog, in de je appdelegate een break point zetten en daar al je code heen lopen.
Je zal er op die manieren achter komen waar hij vast loopt.
  #7  
Oud 8 October 2010, 12:21
Zaankantertje75's schermafbeelding
» Ik heb geen iPhone  
» Mac OS X
 
Geregistreerd: 6 October 2010
Locatie: Zaandam
Berichten: 42
Send a message via twitter to Zaankantertje75
Standaard

Citaat:
Oorspronkelijk geplaatst door TUX2K Bekijk bericht
Oke, als je applicatie draait op je telefoon via de debugger in XCode dan kan je zien waar vast loopt.
In de balk in de source code scherm zit een dropdown lijstje, hier kan je op klikken en dan zie je de methode die worden aangeroepen, en dus ook die gene waar hij op vast loopt.

Je kom ook nog, in de je appdelegate een break point zetten en daar al je code heen lopen.
Je zal er op die manieren achter komen waar hij vast loopt.
Hahah ik ben nieuw met xCode hea werk er pas sinds maandag mee.

ik draai hem trouwens op een simulator niet op een iPhone.

maar goed ik ging naar de menu run en toen deed ik debug. dus ik build and debug nu in de debiuger.

Maar source code balk? is dat in het xCode scherm zelf? ik zie boven me code. 2 dropdown menus 1 aan de het begin en i aan het eind

de eerste zegt: Thread-1-<com.apple.main-trhead>
de tweede zegt __kill

Haha ik voel me echt dom nu

Dus heb ik hem laten lopen in de debugger.
  #8  
Oud 8 October 2010, 12:45
» iPhone 5 16GB (Wit) [FW: 8.1.2]  [Jailbreak: Nee]
» iPad mini Wi-Fi 16GB (Zwart) [FW: 8.1.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 27 October 2008
Locatie: Amsterdam
Berichten: 174
Standaard

Klik maar eens op die __kill.
Dan moet je een lijst krijgen met methode die worden uitgevoerd.
En hier zie je ook je eigen methode naast die van CocoaTouch (api's van apple).
En loop daar door heen.

Stop het debuggen niet, dus gewoon je gecashde app laten lopen, anders ben je je bebug infromatie kwijt.
  #9  
Oud 8 October 2010, 12:58
Zaankantertje75's schermafbeelding
» Ik heb geen iPhone  
» Mac OS X
 
Geregistreerd: 6 October 2010
Locatie: Zaandam
Berichten: 42
Send a message via twitter to Zaankantertje75
Standaard

Citaat:
Oorspronkelijk geplaatst door TUX2K Bekijk bericht
Klik maar eens op die __kill.
Dan moet je een lijst krijgen met methode die worden uitgevoerd.
En hier zie je ook je eigen methode naast die van CocoaTouch (api's van apple).
En loop daar door heen.

Stop het debuggen niet, dus gewoon je gecashde app laten lopen, anders ben je je bebug infromatie kwijt.
Ok tx!

me warnings zijn nu weg.

Alleen me applicatie wilt nog steeds niet goed laden.

ik zie me laad scherm en dan opent ie me achtergrond maar mijn labels buttons en textfields zijn weg. incusief me tabbar :S
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
Wilt pagina's niet laden rsdragonboy Wi-Fi 0 13 August 2010 23:44
HELP! Mijn iPhone wilt niet meer herstellen! Jhlsa iPhone algemeen 0 30 June 2010 12:11
iPod touch: Mijn iTouch 3G (3.1.3) wilt niet downgraden iMonzter Jailbreak 0 19 April 2010 22:25

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 00:28.