App uitbrengen onder 3.1.3 of 4.1?

App uitbrengen onder 3.1.3 of 4.1? discussie in Ontwikkelen voor iOS forum; ( verdwijnt na registratie ) Ik twijfel hoe ik mijn nieuwe Apps binnenkort ga uitbrengen. Ik kan kiezen tussen 2 target platforms. Ze hebben beide voor- en nadelen: iOS versie ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > Development > Ontwikkelen voor iOS
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen
  #1  
Oud 21 October 2010, 09:47
» iPhone 4 32GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» iPad 3 Wi-Fi 16GB (Zwart) [FW: 5.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 14 October 2008
Locatie: Haarlem
Berichten: 348
Standaard App uitbrengen onder 3.1.3 of 4.1?

Ik twijfel hoe ik mijn nieuwe Apps binnenkort ga uitbrengen. Ik kan kiezen tussen 2 target platforms. Ze hebben beide voor- en nadelen:
  1. iOS versie 3.1.3. Nu bereik ik de meeste gebruikers: iPod Touch (1st and 2nd generation) en alle andere iOS devices.
  2. iOS versie 4.1. Nu schakel ik de iPod Touch gebruikers uit, maar kan ik geen gebruik maken van 'Fast App Switching' (doorgaan in de staat die de App had toen je hem afsloot) en Multitasking. Daarvoor moet je de App uitbrengen onder 4.0 of hoger.

Misschien moet ik de App wel in twee versies uitbrengen. Of zijn er andere oplossingen die ik nog niet zie?
__________________
Leon
[iPhone- en Java ontwikkelaar]
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 21 October 2010, 10:14
sukk1e's schermafbeelding
» iPhone 4 32GB (Zwart) [FW: 5.0.1]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 27 April 2010
Berichten: 134
Standaard

Geen idee of er andere oplossingen zouden zijn, lijkt me niet eigenlijk.
Maja zou je echt fast app switching nodig hebben of multitasken?

Hangt af van de applicatie. Als het geen hulpmiddel is, waardoor je veel zou moeten switchen, zou ik gewoon builden voor 3.1.3. Ik ga er niet van uit dat mensen ineens een actie sluiten als ze bezig zijn dus waarom zouden ze graag deze feature willen hebben?

Uiteindelijk draait het om het cashen.
  #3  
Oud 21 October 2010, 10:32
» iPhone 5 16GB (Wit) [FW: 8.1.2]  [Jailbreak: Nee]
» iPad mini Wi-Fi 16GB (Zwart) [FW: 8.1.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 27 October 2008
Locatie: Amsterdam
Berichten: 174
Standaard

Ik bouw zelf alle apps in 4.1 met als deployment target 3.1
Nu lopen apps dus ook op iOS 3.1.3 en 4.0, tevens hebben ze dan standaard gewoon fast app switching als dit wordt ondersteund.

Als je specifieke iOS 4 methode wil gebruiken moet je eesrte even controleren of de methode/klasse beschikbaar is. Apple heeft daar documentatie voor, echter kan ik hem niet zo snel vinden.

Apple accepteert enkel apps welke zijn gebouwd met SDK 4.0 of hoger,
  #4  
Oud 21 October 2010, 10:44
» iPhone 4 32GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» iPad 3 Wi-Fi 16GB (Zwart) [FW: 5.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 14 October 2008
Locatie: Haarlem
Berichten: 348
Standaard

Citaat:
Oorspronkelijk geplaatst door TUX2K Bekijk bericht
Ik bouw zelf alle apps in 4.1 met als deployment target 3.1. Nu lopen apps dus ook op iOS 3.1.3 en 4.0, tevens hebben ze dan standaard gewoon fast app switching als dit wordt ondersteund.
is dat zo? Dan is dit dus de oplossing!
Ik ga het proberen. Thanks!
  #5  
Oud 22 October 2010, 17:52
» iPhone 5s 16GB (Space Grijs) [FW: 7.1.1]  [Jailbreak: Nee]
» iPad 1 Wi-Fi 16GB [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 27 February 2009
Berichten: 429
Standaard

Citaat:
Oorspronkelijk geplaatst door wubbe Bekijk bericht
is dat zo? Dan is dit dus de oplossing!
Ik ga het proberen. Thanks!
Heb ook ik hoor, mijn applicatie kan vanaf 3.0 worden gebruikt uiteraard hebben de mensen op 3.0 geen multitasking maar mensen die hem op 4.0 of hoger hebben hebben wel multitasking (als hun apparaat het ondersteund).

Laatst gewijzigd door Dreissen; 22 October 2010 om 18:01. Reden: foutje
  #6  
Oud 23 October 2010, 17:39
Santiago's schermafbeelding
» iPhone 4 16GB (Zwart) [FW: 4.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 2 October 2010
Locatie: Amersfoort
Berichten: 51
Standaard

Zijn er geen statistieken bekend met gebruikers per iOS versie? Binnenkort heb ik waarschijnlijk dit probleem ook.
  #7  
Oud 24 October 2010, 17:26
» iPhone 4 32GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» iPad 3 Wi-Fi 16GB (Zwart) [FW: 5.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 14 October 2008
Locatie: Haarlem
Berichten: 348
Standaard

@Santiago
Je hebt het probleem niet. Gewoon met de SDK 4.1 bouwen en als target platform 3.1 instellen, zoals hierboven beschreven.

En als je specifieke 4.0 functionaliteit wilt gebruiken eerst checken of het platform dat ondersteund.

Wat heb je nog voor probleem dan?
  #8  
Oud 5 November 2010, 09:33
» iPhone 4 32GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» iPad 3 Wi-Fi 16GB (Zwart) [FW: 5.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 14 October 2008
Locatie: Haarlem
Berichten: 348
Standaard En de iPad dan?

Als ik mijn App bouw met als target platform iOS 3.1.3 en ik zeg tegen de simulator in XCode dat het een iPad is, dan crasht mijn App.

Dat is het geval als ik in de build properties als target device iPhone/iPad instel.

Hoe zorg ik er voor dat mijn App ook op de iPad draait? En dan bedoel ik niet als 'native'' iPad App maar gewoon als iPhone App.

Laatst gewijzigd door wubbe; 8 November 2010 om 23:03.
  #9  
Oud 5 November 2010, 10:01
» iPhone 5 16GB (Wit) [FW: 8.1.2]  [Jailbreak: Nee]
» iPad mini Wi-Fi 16GB (Zwart) [FW: 8.1.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 27 October 2008
Locatie: Amsterdam
Berichten: 174
Standaard

Je app crasht waarschijnlijk omdat je een iOS 4.* methode/klasse gebruikt.
Probeer de foutmelding maar eens te google.
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
"kenteken" app eindelijk werkend onder 3GS MCNO iPhone Apps 5 9 January 2010 14:46
App: alle iconen onder elkaar sabhazi Jailbreak apps en thema's 6 30 September 2008 14:21
[FW 2.0] Hulp nodig bij aanpassen/verwijderen van text onder App Store applicaties McHenk iPhone Apps 2 24 July 2008 22:37

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 21:18.