Waarom doen we niet aan software porten op iPhone?

Waarom doen we niet aan software porten op iPhone? discussie in iPhone algemeen forum; ( verdwijnt na registratie ) Hoi, ik ben nieuw op dit forum, ik ben al ongeveer een jaar iPhone gebruiker, eigenaar van een iPhone 4 16GB Ik heb geen idee ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > iPhone > iPhone algemeen
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen
  #1  
Oud 17 July 2014, 14:20
» iPhone 4 16GB (Zwart) [FW: 7.1.2]  [Jailbreak: Ja]
» Ik heb geen iPad  
» Windows
 
Geregistreerd: 17 July 2014
Berichten: 4
Post Waarom doen we niet aan software porten op iPhone?

Hoi, ik ben nieuw op dit forum, ik ben al ongeveer een jaar iPhone gebruiker, eigenaar van een iPhone 4 16GB

Ik heb geen idee of ik dit in het juiste forum vraag, mijn excuses als ik het topic in het verkeerde forum aangemaakt heb

Ik zat met een vraag: Ik heb hier nog een oud Android model liggen, deze is al lang niet meer ondersteund en draait als laatste officiele versie Android 4.1.2.
Maar; een stelletje developers hebben de laatste Android versie 4.4.x geport zodat het toestel toch die nieuwere software kan draaien, wel onofficieel en niet helemaal stabiel.

Nu is mijn vraag: Waarom doet of kan dit niet met een iPhone? Is het gewoon onmogelijk om de nieuwere software, iOs 8 die uit gaat komen, onofficieel naar de iPhone 4 te porten? Ik wil het wel proberen maar heb geen idee waar te beginnen. Gewoon het .plist bestandje aanpassen om iTunes om de tuin te lijden gaat denk ik een brick opleveren.

Heeft iemand enig idee?
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 17 July 2014, 14:26
» iPhone SE 128GB (Goud) [FW: 11.0 beta]  [Jailbreak: Nee]
» iPad Pro 9,7 Wi-Fi + 4G 256GB (Goud) [FW: 11.0 beta]  [Jailbreak: Nee]
» Anders
 
Geregistreerd: 1 July 2010
Locatie: /private/etc/
Berichten: 25.085
Standaard

Citaat:
Oorspronkelijk geplaatst door domini99 Bekijk bericht
Heeft iemand enig idee?
Gaat nooit werken. Om tientallen redenen.
  #3  
Oud 17 July 2014, 14:28
» Ik heb geen iPhone  
» iPad 4 Wi-Fi 32GB (Zwart) [FW: 10.3.2]  [Jailbreak: Nee]
» Windows
 
Geregistreerd: 19 October 2010
Locatie: Zoetermeer
Berichten: 743
Standaard

Ieder bestand in de software verwijst naar een hardware nummer als N72AP(iPod touch 2e gen.) Ook de kernel is voor een specifieke processor gemaakt (en geen enkel ander apparaat met de Apple A4 chip kan ios 8 aan). Zelfs al zou je dat fixen dan kun je het nog niet installeren omdat er geen SHSH blobs voor de iPhone 4 op iOS 8.X bestaan.
__________________
iPod touch 2G 8GB (25-09-2009 - 01-06-2011) ->
iPod touch 4G 32GB (27-01-2011 - verkocht) ->iPad 4 32GB (15-07-2013 - nu)
  #4  
Oud 17 July 2014, 14:30
» iPhone SE 128GB (Goud) [FW: 11.0 beta]  [Jailbreak: Nee]
» iPad Pro 9,7 Wi-Fi + 4G 256GB (Goud) [FW: 11.0 beta]  [Jailbreak: Nee]
» Anders
 
Geregistreerd: 1 July 2010
Locatie: /private/etc/
Berichten: 25.085
Standaard

Citaat:
Oorspronkelijk geplaatst door arjan95 Bekijk bericht
Zelfs al zou je dat fixen dan kun je het nog niet installeren omdat er geen SHSH blobs voor de iPhone 4 op iOS 8.X bestaan.
SHSH hashes werken sinds iTunes 11.1 toch al niet meer door random SHSH generation.
  #5  
Oud 17 July 2014, 14:30
» iPhone 4 16GB (Zwart) [FW: 7.1.2]  [Jailbreak: Ja]
» Ik heb geen iPad  
» Windows
 
Geregistreerd: 17 July 2014
Berichten: 4
Standaard

Citaat:
Oorspronkelijk geplaatst door arjan95 Bekijk bericht
Ieder bestand in de software verwijst naar een hardware nummer als N72AP(iPod touch 2e gen.) Ook de kernel is voor een specifieke processor gemaakt (en geen enkel ander apparaat met de Apple A4 chip kan ios 8 aan). Zelfs al zou je dat fixen dan kun je het nog niet installeren omdat er geen SHSH blobs voor de iPhone 4 op iOS 8.X bestaan.
Mmmmhhh ja die SHSH blob daar zeg je wat.
Mijn SHSH blobs van iOS 6 werkte ook niet om te downgraden.
  #6  
Oud 17 July 2014, 14:33
» iPhone SE 128GB (Goud) [FW: 11.0 beta]  [Jailbreak: Nee]
» iPad Pro 9,7 Wi-Fi + 4G 256GB (Goud) [FW: 11.0 beta]  [Jailbreak: Nee]
» Anders
 
Geregistreerd: 1 July 2010
Locatie: /private/etc/
Berichten: 25.085
Standaard

Citaat:
Oorspronkelijk geplaatst door domini99 Bekijk bericht
Mijn SHSH blobs van iOS 6 werkte ook niet om te downgraden.
Wel met iTunes 11.0 of ouder.
  #7  
Oud 17 July 2014, 14:35
» iPhone 4 16GB (Zwart) [FW: 7.1.2]  [Jailbreak: Ja]
» Ik heb geen iPad  
» Windows
 
Geregistreerd: 17 July 2014
Berichten: 4
Standaard

Citaat:
Oorspronkelijk geplaatst door timosha Bekijk bericht
Wel met iTunes 11.0 of ouder.
Nee, iFaith weigerde een IPSW te maken. Ook al voordat iOS 7 uit was, ik heb op verschillende manieren geprobeert mijn SHSH blobs uit mijn iPhone te halen, maar iedere keer vertikte iFaith het. Mijn iOs 5 blobs werken wel. (de iPhone heeft nog een leven gehad voordat ik 'm kreeg, de vorige eigenaar heeft alle SHSH blobs vanaf iOs 4 opgeslagen en aan mij gegeven)
  #8  
Oud 17 July 2014, 14:39
» iPhone SE 128GB (Goud) [FW: 11.0 beta]  [Jailbreak: Nee]
» iPad Pro 9,7 Wi-Fi + 4G 256GB (Goud) [FW: 11.0 beta]  [Jailbreak: Nee]
» Anders
 
Geregistreerd: 1 July 2010
Locatie: /private/etc/
Berichten: 25.085
Standaard

Citaat:
Oorspronkelijk geplaatst door domini99 Bekijk bericht
Nee, iFaith weigerde een IPSW te maken.
Ja, ik heb het een keer of vijf (5) gedaan met een iPhone 4. Downgraden met iTunes 11.0 van iOS 7 naar iOS 6.1.3 met de opgeslagen SHSH hashes werkte perfect. Maar daar gaat het hier niet over.

Dus nogmaals: wat jij wil is zo goed als onmogelijk. Succes verder.
  #9  
Oud 17 July 2014, 14:45
» iPhone 4 16GB (Zwart) [FW: 7.1.2]  [Jailbreak: Ja]
» Ik heb geen iPad  
» Windows
 
Geregistreerd: 17 July 2014
Berichten: 4
Standaard

Citaat:
Oorspronkelijk geplaatst door timosha Bekijk bericht
Ja, ik heb het een keer of vijf (5) gedaan met een iPhone 4. Downgraden met iTunes 11.0 van iOS 7 naar iOS 6.1.3 met de opgeslagen SHSH hashes werkte perfect. Maar daar gaat het hier niet over.

Dus nogmaals: wat jij wil is zo goed als onmogelijk. Succes verder.
Ik ga niks proberen, want ik heb geen idee wat ik aan het doen ben. De kans om je iPhone te hardbricken is veel groter dan de kans dat je een Android hardbricked bij het flashen van custom firmware.
  #10  
Oud 17 July 2014, 16:31
» iPhone 5c 16GB (Blauw) [FW: 7.1.2]  [Jailbreak: Nee]
» iPad mini Wi-Fi 16GB (Zwart) [FW: 7.0.4]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 12 February 2010
Locatie: soest
Berichten: 519
Standaard

Citaat:
Oorspronkelijk geplaatst door domini99 Bekijk bericht
...Maar; een stelletje developers hebben de laatste Android versie 4.4.x geport zodat het toestel toch die nieuwere software kan draaien, wel onofficieel en niet helemaal stabiel.

Nu is mijn vraag: Waarom doet of kan dit niet met een iPhone?...
Je geeft zelf het antwoord al. Zelfs op een volledig open liggend systeem als Android is de zooi al niet stabiel.

Laat staan dat je dit op het gesloten iOS lekker werkend gaat krijgen.
Dat moet je niet willen. En is zonde van je tijd om je daar mee bezig te houden.
  #11  
Oud 17 July 2014, 17:43
» Ik heb geen iPhone  
» iPad 4 Wi-Fi 32GB (Zwart) [FW: 10.3.2]  [Jailbreak: Nee]
» Windows
 
Geregistreerd: 19 October 2010
Locatie: Zoetermeer
Berichten: 743
Standaard

Het verste waar ze ooit in deze richting mee zijn gekomen is het iDroid project: een versie van Android voor de iPhone (2007), iPhone 3G en de iPod touch 1e generatie. Het werkte natuurlijk voor geen meter (1 uur accu, geen videoversnelling , geen mobiel internet etc.) maar het was wel gaaf dat het überhaupt kon. Verder is zoiets nooit gebeurt.
  #12  
Oud 17 July 2014, 19:03
XIII's schermafbeelding
iPhone(club) Guru
» iPhone 6 128GB (Space Grijs) [FW: 10.3.3]  [Jailbreak: Nee]
» iPad Pro 10,5 Wi-Fi + 4G 256GB (Spacegrijs) [FW: 10.3.3]  [Jailbreak: Nee]
» Windows
 
Geregistreerd: 1 July 2009
Berichten: 9.855
Standaard

Citaat:
Oorspronkelijk geplaatst door domini99 Bekijk bericht
Nu is mijn vraag: Waarom doet of kan dit niet met een iPhone?
Omdat de broncode van iOS niet buiten Apple beschikbaar is.
__________________
We are one, but we are not the same... Talk to each other!
  #13  
Oud 17 July 2014, 20:16
» iPhone 5s 32GB (Space Grijs) [FW: 8.1.3]  [Jailbreak: Nee]
» iPad 3 Wi-Fi 32GB (Zwart) [FW: 8.0.2]  [Jailbreak: Nee]
» Windows
 
Geregistreerd: 6 March 2009
Locatie: westland
Berichten: 64
Standaard iphone

kijk hier eens het is voor jouw niet de oplossing misschien in de toekomst

Whited00r NL | iOS Community Custom Firmware
  #14  
Oud 17 July 2014, 20:23
» iPhone SE 128GB (Goud) [FW: 11.0 beta]  [Jailbreak: Nee]
» iPad Pro 9,7 Wi-Fi + 4G 256GB (Goud) [FW: 11.0 beta]  [Jailbreak: Nee]
» Anders
 
Geregistreerd: 1 July 2010
Locatie: /private/etc/
Berichten: 25.085
Standaard

Citaat:
Oorspronkelijk geplaatst door normalis666 Bekijk bericht
kijk hier eens het is voor jouw niet de oplossing misschien in de toekomst
Whited00r is al zo oud als de straat en is in ieder geval geen port van een iOS versie die niet geschikt is voor de bedoelde toestellen.
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
Mijn iPhone 4 gaat helemaal niet meer aan, wat moet ik doen? Gul25 iPhone algemeen 16 6 July 2013 11:26
Alle iDevices: Jailbreak, waarom moet iedereen hetzelfde doen? Ruben.cc Jailbreak 5 20 May 2011 12:47
Synchronisatie mislukt, kan nu geen software update doen? Cilia iTunes 0 25 June 2010 07:11
Lights Off App porten Vsteegman Ontwikkelen voor iOS 1 6 December 2008 14:38

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 02:16.