Uitschakelen PassLock / Exchange Push Email

Uitschakelen PassLock / Exchange Push Email discussie in iPhone algemeen forum; ( verdwijnt na registratie ) [Lees even de hele thread - het werkt nl nog niet goed] Hallo, Vanmiddag op de zaak gelijk exchange push email ingesteld. Werkt echt super ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > iPhone > iPhone algemeen
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen
  #1  
Oud 22 July 2008, 00:01
» iPod touch 32GB (v3) [FW: 4.3.3]  [Jailbreak: Nee]
» iPad 1 Wi-Fi + 3G 16GB [FW: 5.0 Beta]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 8 November 2007
Locatie: IJsselstein
Berichten: 37
Talking Uitschakelen PassLock / Exchange Push Email

[Lees even de hele thread - het werkt nl nog niet goed]

Hallo,

Vanmiddag op de zaak gelijk exchange push email ingesteld.
Werkt echt super alleen soms wat vertraging om contacts op te starten. Maar nu on-topic...

Tot mijn verbazing wordt je na het instellen van Exchange Push email geforceerd om een complex passlock wachtwoord in te stellen. Een combinatie van minimaal 6 karakters, cijfers en speciale tekens.

Nu kan ik me niet voorstellen dat dit door onze Admin's geforceerd wordt. Wij zijn een blackberry shop - en push email wordt niet officieel ondersteunt of gebruikt. Waarschijnlijk zijn dit dus de standaard instellingen van Apple bij het configureren van Push Email voor Exchange.

Ik begrijp wel dat dit om veiligheids redenen is gedaan, maar om nu elke 5 minuten een complex wachtwoord in te typen voordat de telefoon weer gebruikt kan worden gaat mij te ver.

Via het menu van de iPhone is de passlock in iedergeval niet uit te zetten of een minder complexe wachtwoord te kiezen zolang exchange push email aktief is. Nadat je het Exchange Account verwijderd heb kan ook de passlock weer uitgezet worden.

De oplossing is eigenlijk vrij simpel, echter je moet wel SSH toegang tot je iPhone hebben. Weet je niet wat SSH is, en heb je geen linux/unix achtige basis kennis dan zou ik dit niet proberen.

Login op je iPhone met SSH en volg onderstaande commando's.

Citaat:

rm /private/var/Managed Preferences/mobile/com.apple.springboard.plist

Of als je een backup wilt:

mv /private/var/Managed Preferences/mobile/com.apple.springboard.plist /private/var/Managed Preferences/mobile/com.apple.springboard.plist.bk

cd /private/var/Managed Preferences/

chown root:wheel mobile/
De passlock is nu uitgeschakeld. LET OP: Je kan nu geen passlock meer instellen. De instellingen worden niet meer bewaard.

Veel plezier.
Bjorn.

Laatst gewijzigd door bwbboot; 25 July 2008 om 22:51.
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 22 July 2008, 00:03
iCulture's schermafbeelding
Administrator
» iPhone 7 128GB (Roségoud) [FW: 11.0]  [Jailbreak: Nee]
» iPad Pro 10,5 Wi-Fi + 4G 512GB (Roségoud) [FW: 11.0]  [Jailbreak: Nee]
» macOS
 
Geregistreerd: 15 September 2007
Locatie: Amsterdam
Berichten: 28.450
Stuur een bericht via Instant Messenger naar iCulture Stuur een bericht via Skype™ naar iCulture Send a message via twitter to iCulture
Standaard

Citaat:
Oorspronkelijk geplaatst door bwbboot Bekijk bericht
Tot mijn verbazing wordt je na het instellen van Exchange Push email geforceerd om een complex passlock wachtwoord in te stellen. Een combinatie van minimaal 6 karakters, cijfers en speciale tekens.
Dit lijkt me toch iets specifiek voor jullie Exchange-configuratie, want ik ben deze melding nog helemaal niet tegengekomen en gezien de stilte van andere gebruikers is het ook geen algemeen probleem. Misschien eens met de server admins praten?
  #3  
Oud 22 July 2008, 00:10
» iPod touch 32GB (v3) [FW: 4.3.3]  [Jailbreak: Nee]
» iPad 1 Wi-Fi + 3G 16GB [FW: 5.0 Beta]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 8 November 2007
Locatie: IJsselstein
Berichten: 37
Standaard

Ja dat zou natuurlijk kunnen. Wellicht dat de wachtwoord eisen van Active Directory worden overgenomen. Daar zijn bij ons wel complexe wachtwoorden vereist. In iedergeval mijn complimenten aan Apple voor de Integratie met Exchange/AD. Lijkt goed in orde te zijn.

Bjorn.
  #4  
Oud 22 July 2008, 00:17
iCulture's schermafbeelding
Administrator
» iPhone 7 128GB (Roségoud) [FW: 11.0]  [Jailbreak: Nee]
» iPad Pro 10,5 Wi-Fi + 4G 512GB (Roségoud) [FW: 11.0]  [Jailbreak: Nee]
» macOS
 
Geregistreerd: 15 September 2007
Locatie: Amsterdam
Berichten: 28.450
Stuur een bericht via Instant Messenger naar iCulture Stuur een bericht via Skype™ naar iCulture Send a message via twitter to iCulture
Standaard

Citaat:
Oorspronkelijk geplaatst door bwbboot Bekijk bericht
Ja dat zou natuurlijk kunnen. Wellicht dat de wachtwoord eisen van Active Directory worden overgenomen. Daar zijn bij ons wel complexe wachtwoorden vereist. In iedergeval mijn complimenten aan Apple voor de Integratie met Exchange/AD. Lijkt goed in orde te zijn.
Overigens wel bedankt voor je oplossing! Dat was ik nog vergeten te zeggen
  #5  
Oud 22 July 2008, 11:53
» iPhone 4 32GB (Zwart) [FW: 4.3.3]  [Jailbreak: Ja]
» iPad 1 Wi-Fi + 3G 16GB [FW: 4.3.3]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 20 March 2008
Locatie: Kippenhok van NL
Berichten: 27
Stuur een bericht via ICQ naar coolhva Stuur een bericht via Instant Messenger naar coolhva Stuur een bericht via MSN naar coolhva Stuur een bericht via Yahoo naar coolhva Stuur een bericht via Skype™ naar coolhva Send a message via twitter to coolhva
Standaard

hmmz, de enige manier waarop dit mogelijk zou kunnen zijn lijkt mij is als je met de config tool van apple exchange hebt ingesteld en ook de passlock hebt aangezet. Heb je een "profiel" geďnstalleerd?
  #6  
Oud 23 July 2008, 00:09
» iPod touch 32GB (v3) [FW: 4.3.3]  [Jailbreak: Nee]
» iPad 1 Wi-Fi + 3G 16GB [FW: 5.0 Beta]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 8 November 2007
Locatie: IJsselstein
Berichten: 37
Standaard

Het lijkt er nu inderdaad op dat dit door de Admins is gedaan. Zojuist om middennacht kreeg ik opnieuw de melding om een passcode in te stellen. Misschien wordt dit dagelijks opnieuw gepushed.

Ik zag even snel het schermpje Profiles voorbij vliegen, maar daar stond verder niks vermeld. Kan daar ook niet bij komen op een of andere manier.

Gelijk even de file /Library/ManagedPreferences/mobile/com.apple.springboard.plist weer aangepast zodat de passlock weer te verwijderen is. Ik heb nu ook de rechten van de file van mobile:mobile naar root:wheel gezet. Hopelijk kan je hiermee voorkomen dat het profiel opnieuw wordt ingesteld.

EDIT: Ok, de rechten wijzigen helpt ook niet. Als ik nu met de hand weer een passcode instel worden de rechten van het bestand opnieuw op mobile:mobile gezet. Dit moet toch op een of andere manier te blokkeren zijn?

Laatst gewijzigd door bwbboot; 23 July 2008 om 00:14.
  #7  
Oud 23 July 2008, 00:46
» iPod touch 32GB (v3) [FW: 4.3.3]  [Jailbreak: Nee]
» iPad 1 Wi-Fi + 3G 16GB [FW: 5.0 Beta]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 8 November 2007
Locatie: IJsselstein
Berichten: 37
Standaard

Goed nieuws...Het lijkt nu goed gelukt.

De dir /Library/ManagedPreferences/mobile/directory is eigenlijk een symlink naar de directory /private/var/Managed Preferences/mobile

Door op de laatste directory mobile de rechten aan te passen naar root:wheel door middel van het commando chown root:wheel mobile/ kan de file com.apple.springboard.plist niet meer aangemaakt of gewijzigt worden. De file zelf heb ik verwijderd (zekere voor het onzekere).

Als je nu een nieuwe passcode instelt worden de instellingen niet weggeschreven in de configuratie file of een nieuwe file aangemaakt. Het lijkt net alsof de passcode wordt geaccepteerd, echter als je opnieuw naar de passcode instellingen gaat staat deze weer keurig op UIT.

Laatst gewijzigd door bwbboot; 23 July 2008 om 00:52.
  #8  
Oud 23 July 2008, 20:26
» iPhone 4 32GB (Zwart) [FW: 4.0.1]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 9 February 2008
Locatie: Groningen
Berichten: 76
Send a message via twitter to Snowgasm
Standaard

Hey, thanx. Hier was ik dus naar op zoek.

Exchange draait nu op en top hier.
  #9  
Oud 25 July 2008, 22:45
» iPod touch 32GB (v3) [FW: 4.3.3]  [Jailbreak: Nee]
» iPad 1 Wi-Fi + 3G 16GB [FW: 5.0 Beta]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 8 November 2007
Locatie: IJsselstein
Berichten: 37
Standaard

En ook helaas houdt deze methode geen stand.

De Policy instellingen worden door de exchange server gepushed naar de iphone. Dit kun je op exchange instellen via de system manager (zie screenshot).




Belangrijk hier is de "Refresh settings on the device (hours)".

Dit betekend dus dat -standaard- elke 24 uur de policy opnieuw naar de iphone wordt gepushed.

Met de door mij omschreven procedure is het niet meer mogelijk om een passcode in te stellen.

Op het moment dat -door exchange gepushed- de passcode weer opnieuw moet worden ingesteld komt de iphone in een loop. Er wordt namelijk gecontroleerd of de passcode idd goed is ingesteld. En dit kan niet meer. De enige optie is dan om het instellen van de passcode te annuleren. Echter dan stopt de iphone met het synchroniseren van de mail.

Ik zit dus even zonder opties hier.. iemand anders nog ideeen??

EDIT: Met ideeen bedoel ik natuurlijk een hack op de iphone. Niet dat ik de Exchange admin's moet vragen de instellingen op exchange te veranderen.

Laatst gewijzigd door bwbboot; 25 July 2008 om 22:50.
  #10  
Oud 30 July 2008, 22:32
» iPhone US 8GB [FW: 3.0]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 8 December 2007
Berichten: 10
Standaard

een oplossing uit een of andere iphone forum waar ik met googlen terecht kwam en die prima werkt:
--
How to disable Exchange PIN requirement.

a. Jailbreak.
b. SSH into the phone as [ root ]
c. Edit the following file [ "/var/Managed Preferences/mobile/com.apple.springboard.plist" ]
d. Make the following change, setting of the key "minLength" to zero.

<key>PolicyInformation</key>
<dict>
<key>maxFailedAttempts</key>
<integer>10</integer>
<key>maxInactivity</key>
<integer>60</integer>
<key>minLength</key>
<integer>0</integer>
</dict>

e. Now go into preferences and turn autolock off.
--
wijziging terugdraaien gaat prima door van de 0 weer te veranderen in de oude waarde, ik meen 4.
  #11  
Oud 31 July 2008, 00:08
» iPod touch 32GB (v3) [FW: 4.3.3]  [Jailbreak: Nee]
» iPad 1 Wi-Fi + 3G 16GB [FW: 5.0 Beta]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 8 November 2007
Locatie: IJsselstein
Berichten: 37
Standaard

Ja dat klopt. Alleen worden de instellingen weer opnieuw gezet door de policy van de exchange server. Dit betekend dus dat je elke 24 uur de wijziging moet doorvoeren.
  #12  
Oud 2 August 2008, 13:46
» iPhone US 8GB [FW: 2.0]
» MacOS X
 
Geregistreerd: 18 September 2007
Berichten: 38
Standaard

Edit: Never mind, schijnt niet te werken: https://forum.iculture.nl/f8/ap...hangelock.html

Sinds vandaag staat in Cydia het programma KillExchangeLock. Geen idee of je hiermee de 24uur overbrugt.

Laatst gewijzigd door BOlle; 2 August 2008 om 13:50.
  #13  
Oud 8 August 2008, 16:43
» iPhone 4 32GB (Zwart) [FW: 5.1.1]  [Jailbreak: Ja]
» iPad 3 Wi-Fi 32GB (Wit) [FW: 5.1.1]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 5 August 2008
Locatie: Groningen
Berichten: 36
Standaard

Dat tooltje doet bij mij niks. Nog steeds elk uur ofzo passcode invoeren. Exchange er maar weer afgegooid, want zo is er echt niet mee te werken.
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
Synchronisatie email via exchange server Watikjebrom iTunes 5 5 January 2010 10:44
Email (exchange) Layout en tasks? Sterke-Jerke iPhone algemeen 1 13 September 2009 11:01
push mail via exchange artworx iPhone algemeen 5 20 July 2009 23:45
Gratis Push email via Microsoft Exchange Stiruam iPhone algemeen 20 29 June 2009 14:10
Exchange email op iphone zonder exchange server iNiels iPhone algemeen 0 12 February 2009 10:26

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 10:18.