Toevoegen framework in XCode 3.2 (SL) geeft fouten

Toevoegen framework in XCode 3.2 (SL) geeft fouten discussie in Ontwikkelen voor iOS forum; ( verdwijnt na registratie ) Sinds ik XCode 3.2 heb in Snow Leopard, krijg ik steeds, als ik een bestaand project pak en een framework toevoeg (stel, MPMediaPlayer.framework), het volgende ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > Development > Ontwikkelen voor iOS
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen
  #1  
Oud 6 September 2009, 18:35
Malork's schermafbeelding
» iPhone 4S 32GB (Wit) [FW: 5.1.1]  [Jailbreak: Nee]
» iPad 3 Wi-Fi + 4G 16GB (Zwart) [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 1 June 2008
Locatie: Landgraaf
Berichten: 178
Stuur een bericht via MSN naar Malork
Standaard Toevoegen framework in XCode 3.2 (SL) geeft fouten

Sinds ik XCode 3.2 heb in Snow Leopard, krijg ik steeds, als ik een bestaand project pak en een framework toevoeg (stel, MPMediaPlayer.framework), het volgende probleem als ik wil testen op de simulator:

Citaat:
ld: warning: in /Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS3.0.sdk/System/Library/Frameworks/Foundation.framework/Foundation, missing required architecture i386 in file
Dit gebeurt voor ALLE frameworks die erinzitten, terwijl het project 5 seconden geleden nog wel compile'de en de frameworks in/uit exact dezelfde framework-map komen.

Het project is daarna niet meer te redden, althans, mij is het nog niet gelukt. op iPhonedevsdk.com suggereerde iemand dat de SDK 3.1 voor SL alleen het 3.1 framework bevatte, en de overige frameworks een aparte install zijn. Dit klopt, echter na installatie van de overige frameworks blijft het probleem zich voordoen.

Google levert me weinig / geen informatie op, en ik vermoed dat het iets logisch is... op Leopard en XCode 3.1 had ik dit probleem nooit, nu durf je bijna niet te wisselen naar een ander Target OS (2.2.1, 3.0) omdat dit ook hetzelfde probleem kan opleveren.

...help..? Anyone...?

Laatst gewijzigd door Malork; 6 September 2009 om 20:49.
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 6 September 2009, 20:49
Malork's schermafbeelding
» iPhone 4S 32GB (Wit) [FW: 5.1.1]  [Jailbreak: Nee]
» iPad 3 Wi-Fi + 4G 16GB (Zwart) [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 1 June 2008
Locatie: Landgraaf
Berichten: 178
Stuur een bericht via MSN naar Malork
Standaard

nevermind, heb de oplossing al gevonden!

Gewoon bij de info van je target het "Framework Search Paths" wissen. blijkbaar wordt die gevuld als je een framework toevoegd..
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
Vind map TelephonyUI.framework niet! Schepe iPhone algemeen 5 7 January 2010 20:32
Celestial.framework map onvindbaar jurben33 Archief 1 5 November 2009 23:36
.NET Framework 2.0 probleem lukah iPhone algemeen 2 12 August 2008 19:24

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 04:38.