FW 3.0: In Cydia juiste repo aanpassen bij geen Cydia-updates

FW 3.0: In Cydia juiste repo aanpassen bij geen Cydia-updates discussie in Jailbreak apps en thema's forum; ( verdwijnt na registratie ) Na een hoop ellende en vreemde crashes sinds mijn gang naar FW3.0+ jailbreak en op iPC en elders steeds lezen dat er updates van o.a. ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > Jailbreak en Unlock > Jailbreak apps en thema's
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen

Reageren

 

Discussietools Weergave
  #1  
Oud 22 June 2009, 05:52
Buur's schermafbeelding
» iPhone 5s 32GB (Space Grijs) [FW: 8.4]  [Jailbreak: Ja]
» iPad Air Wi-Fi 16GB (Zilver) [FW: 8.4]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 26 July 2008
Locatie: /dev/null
Berichten: 667
Cool FW 3.0: In Cydia juiste repo aanpassen bij geen Cydia-updates

Na een hoop ellende en vreemde crashes sinds mijn gang naar FW3.0+jailbreak en op iPC en elders steeds lezen dat er updates van o.a. Cydia, SBSettings, Five Icon Dock, MobileSubstrate of AptBackup waren, die ik NIET kreeg aangeboden, ben ik eens gaan zoeken naar de oorzaak. Het bleek dat ik nog in de oude saurik repository zat te vissen, van voor FW3.0. Probleem was natuurlijk: hoe pas ik dat aan? Ik wilde niet opnieuw een custom firmware maken...

Mijn oplossing heb ik uitgeschreven in een stappenplannetje, zodat anderen er ook mee geholpen zijn, die tegen hetzelfde oplopen.

Gebruik CyberDuck/Transmit/Putty of eender welk sftp programma om dit bestandje van je iPhone te downloaden naar je computer:
/etc/apt/sources.list.d/saurik.list

Open deze in TextEdit/Teksteditor/Kladblok (let wel op dat je een programma gebruikt dat platte tekst wegschrijft en geen RTF-tekst o.i.d., kijk voor alle zekerheid even de voorkeuren van die teksteditor na hoe het bestand opnieuw bewaard wordt!).

Je ziet nu:

Code:
# do not edit this file to add your own custom sources
# this file is subject to be upgraded as part of a package
# either add your own .list file to /etc/apt/sources.list.d
# or add your entry to the global /etc/apt/sources.list file

deb http://apt.saurik.com/ tangelo main
#deb-src http://apt.saurik.com/ tangelo main
Pas op de een-na-laatste regel het woord 'tangelo' aan naar 'tangelo-3.7', voor de rest niks veranderen!

Zo zou het eruit moeten zien:

Code:
# do not edit this file to add your own custom sources
# this file is subject to be upgraded as part of a package
# either add your own .list file to /etc/apt/sources.list.d
# or add your entry to the global /etc/apt/sources.list file

deb http://apt.saurik.com/ tangelo-3.7 main
#deb-src http://apt.saurik.com/ tangelo main
Bewaar en vervang hierna (met je sftp-programma) die oude saurik.list op je iPhone met de nieuwe, zet de permissies op 644.

Als je hierna Cydia opent, zal deze de nieuwe saurik repo voor FW3.0 gebruiken en zul je om te beginnen direct de opmerking krijgen dat er Essential Updates zijn. Kies voor alles updaten.

Je bent nu weer up-to-date en krijgt ook voortaan de nieuwe updates WEL mee.

P.S. Je kunt (op voorhand al zelfs) nakijken of je de juiste saurik repository voor FW3.0 te pakken hebt, als je in Cydia naar de tab Manage en dan de knop Sources gaat, dan de saurik repo opzoekt (hij heet daar Telesphoreo Tangelo). Er behoort eronder exact te staan "Distribution of Unix Software for iPhoneOS 3". Staat de "3" er niet achter dan zit je nog in de oude repo te vissen. Staat die 3 er wel, dan zit je goed.

Laatst gewijzigd door Buur; 22 June 2009 om 05:56.
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 22 June 2009, 07:26
JWVD's schermafbeelding
» iPhone 4 32GB (Zwart) [FW: 5.0]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 16GB (Wit) [FW: 5.0]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 10 July 2008
Locatie: Renkum
Berichten: 312
Stuur een bericht via Instant Messenger naar JWVD Stuur een bericht via MSN naar JWVD Send a message via twitter to JWVD
Standaard

Bedankt hoor, ik ga het zo wel even proberen
  #3  
Oud 22 June 2009, 12:52
» iPhone 3G 16GB (Zwart) [FW: 3.0]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 21 June 2009
Berichten: 2
Standaard

Ik kan mijn Cydia na de update niet meer vinden, iemand een idee hoe ik die terug kan krijgen? Installer , winterbord etc niet meer zichtbaar...
  #4  
Oud 22 June 2009, 13:17
john1979's schermafbeelding
» iPhone 6 Plus 16GB (Space Grijs) [FW: 8.1.1]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 22 August 2008
Locatie: Haarlem
Berichten: 491
Send a message via twitter to john1979
Standaard

Citaat:
Oorspronkelijk geplaatst door FerryM Bekijk bericht
Ik kan mijn Cydia na de update niet meer vinden, iemand een idee hoe ik die terug kan krijgen? Installer , winterbord etc niet meer zichtbaar...
Na de update naar 3.0 bedoel je?

Opnieuw een jailbreak uitvoeren met Redsn0w
__________________
iPhone 6 Plus 16GB Space Gray | Firmware iOS 8.1.1 | Jailbreak: Nee
  #5  
Oud 22 June 2009, 13:33
» iPhone 3G 16GB (Zwart) [FW: 3.0]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 21 June 2009
Berichten: 2
Standaard

Citaat:
Oorspronkelijk geplaatst door john1979 Bekijk bericht
Na de update naar 3.0 bedoel je?

Opnieuw een jailbreak uitvoeren met Redsn0w

Cydia werkt nu! thanks! alleen nog een manier vinden dat mijn oude progr. er weer op werken. VD woordenboek doet niet meer, trein, Clinometer (v2[1].0) etc. helaas dus nu. Maar bedankt

Laatst gewijzigd door FerryM; 22 June 2009 om 15:40.
  #6  
Oud 22 June 2009, 13:33
mvveelen's schermafbeelding
» iPhone 7 128GB (Zilver) [FW: 10.3.2]  [Jailbreak: Nee]
» iPad 3 Wi-Fi 32GB (Wit) [FW: 7.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 24 November 2008
Locatie: Hoorn NH
Berichten: 1.161
Send a message via twitter to mvveelen
Standaard

Hmmm, ik bleek gelukkig al de juiste repo te hebben, maar een handige tut waarmee een hoop mensen hun voordeel kunnen doen !

Ik probeer sbsettings al enige tijd binnen te halen, maar krijg telkens de melding dat de host unreachable is. Meer mensen met dit probleem ? Is het te druk op hun server ?
  #7  
Oud 22 June 2009, 13:44
» iPhone 5 32GB (Wit) [FW: 6.0.2]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 32GB (Wit) [FW: 6.0]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 29 December 2008
Locatie: Amersfoort
Berichten: 19
Thumbs down

iemand die dit probleem kan oplossen:
couldn't configure pre-depend dpkg for ncursus, probably a dependency cycle

zo kan ik niets updaten...
  #8  
Oud 22 June 2009, 14:38
» iPhone 4 16GB (Wit) [FW: 5.0]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 21 September 2008
Berichten: 36
Standaard

Ik heb vanochtend ook een jailbrake via redSnow gedaan. fijn, supremePrefs, winterboard, sbsettings, etc geinstalleerd enzo. Maar nu verdwijnt ineens mijn statusbar op random momenten...

Iemand die dit ook ervaart?

Laatst gewijzigd door joldemans; 22 June 2009 om 14:41.
  #9  
Oud 22 June 2009, 14:41
Chrisl's schermafbeelding
» iPhone 6s 64GB (Space Grijs) [FW: 9.0.2]  [Jailbreak: Ja]
» iPad Air Wi-Fi 16GB (Spacegrijs) [FW: 7.0.4]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 27 February 2008
Locatie: Amersfoort
Berichten: 2.235
Standaard

Citaat:
Oorspronkelijk geplaatst door joldemans Bekijk bericht
Maar nu verdwijnt ineens mijn statusbar op random momenten...

Dit komt door Supreme prefs, die zijn niet voor 3.0... zou ze er maar gauw weer afgooien....
__________________
2G US 16GB, 3GS 16GB black, 4 32GB black AT&T Simlock, 4S 16GB black, 5S 32GB spacegrey.
  #10  
Oud 22 June 2009, 15:05
» iPhone UK 8GB [FW: 3.1.3]  [Jailbreak: Ja]
» iPad 1 Wi-Fi 16GB [FW: 4.3.3]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 23 May 2008
Berichten: 2
Standaard

Thnx man, werkt nu helemaal prima.

Mocht iemand niet weten hoe je via sftp op je iphone komt (Windows):
Howto: SSH naar je iPhone of iPod touch (Windows) | OSX Mobile.nl
  #11  
Oud 22 June 2009, 15:26
Buur's schermafbeelding
» iPhone 5s 32GB (Space Grijs) [FW: 8.4]  [Jailbreak: Ja]
» iPad Air Wi-Fi 16GB (Zilver) [FW: 8.4]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 26 July 2008
Locatie: /dev/null
Berichten: 667
Standaard

Citaat:
Oorspronkelijk geplaatst door mvveelen Bekijk bericht
Hmmm, ik bleek gelukkig al de juiste repo te hebben, maar een handige tut waarmee een hoop mensen hun voordeel kunnen doen !

Ik probeer sbsettings al enige tijd binnen te halen, maar krijg telkens de melding dat de host unreachable is. Meer mensen met dit probleem ? Is het te druk op hun server ?
Ik HOOP dat veel mensen hier hun voordeel mee hebben en dat we eindelijk eens goed kunnen vergelijken wat er nu wel werkt en wat niet (want dan gebruikt iedereen gelukkig dezelfde versies)! Ik vond het al zo raar dat bij de een pakket X wel werkte en bij de ander niet... Nu krijgen we daar een beetje lijn in, zeker nu er ook een artikel op de voorpagina over geschreven is, zullen wel veel mensen dit lezen en indien nodig, aanpassen.

Wat betreft Host Unreachable in Cydia: je vermoedt het goed. Iedereen is natuurlijk deze dagen aan het updaten geslagen en dat vraagt nogal wat van de repo's... Alleen de repo van saurik moet al 80GB/dag verwerken op dit moment! (bron: een afbeelding van zijn server load).
  #12  
Oud 22 June 2009, 15:36
Buur's schermafbeelding
» iPhone 5s 32GB (Space Grijs) [FW: 8.4]  [Jailbreak: Ja]
» iPad Air Wi-Fi 16GB (Zilver) [FW: 8.4]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 26 July 2008
Locatie: /dev/null
Berichten: 667
Standaard

Citaat:
Oorspronkelijk geplaatst door iphone-fan123 Bekijk bericht
iemand die dit probleem kan oplossen:
couldn't configure pre-depend dpkg for ncursus, probably a dependency cycle

zo kan ik niets updaten...
Ik doe even een gooi... Kijk even na in Cydia: tab Manage > Packages en dan rechtsbovenaan op die knop klikken tot er Expert staat: staan de Core Utilities geinstalleerd? Zoniet, dan probeer dat eerst eens even?
  #13  
Oud 22 June 2009, 15:49
Micronics's schermafbeelding
» iPhone US 16GB [FW: 3.1.3]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 8 April 2008
Locatie: Gelderland
Berichten: 58
Standaard

Wow! Thx!

En gelijk 12 updates! Waarvan 4 Essential.

Ooooww. Hij hangt op Mobile Subtrate, reboot? Nop.. Aj.
In DFU restoren en opnieuw. Nu met Originele Restore, geen custom....
__________________
iPhone 16GB US 1.1.4 OTB no running custom 3.1.2 from @Destiny
Zynga Mafia Wars en Vampires Bloodlust Player ID: 6601 8412 03

Laatst gewijzigd door Micronics; 22 June 2009 om 16:18. Reden: Restoren Noodzakelijk!
  #14  
Oud 22 June 2009, 16:38
shapezzz's schermafbeelding
» iPhone 7 Plus 32GB (Zwart) [FW: 10.1.1]  [Jailbreak: Nee]
» iPad Air Wi-Fi 16GB (Spacegrijs) [FW: 10.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 20 April 2008
Berichten: 694
Standaard

Ik kom met geen mogelijkheid op mijn iPhone met bovengenoemde tools, Transmit op de Mac en WinSCP op Vista lukt het beide niet mee, Toggle-SSH en SBsettings etc. geinstalleerd maar krijg met geen mogelijkheid verbinding.

Iemand een tip misschien ?
  #15  
Oud 22 June 2009, 17:03
Buur's schermafbeelding
» iPhone 5s 32GB (Space Grijs) [FW: 8.4]  [Jailbreak: Ja]
» iPad Air Wi-Fi 16GB (Zilver) [FW: 8.4]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 26 July 2008
Locatie: /dev/null
Berichten: 667
Standaard

Citaat:
Oorspronkelijk geplaatst door shapezzz Bekijk bericht
Ik kom met geen mogelijkheid op mijn iPhone
Ik ken je gevorderdengraad niet, dus ik hou het simpel voor alle zekerheid:
- de meest voor de hand liggende vraag is: is OpenSSH wel geinstalleerd op je iPhone en staat die aan?
- Probeer je het wel op het juiste IP-adres?
- Gebruik je nog steeds het standaardwachtwoord (alpine voor beide users root en mobile) of heb je die veranderd na de upgrade naar 3.0? Hou er rekening mee dat met de upgrade de standaardwachtwoorden weer van kracht zijn (je zal ze dus weer even moeten veranderen, wil je op veilig spelen, maar dat kan natuurlijk alleen maar als je eerst ingelogd kunt komen).

My 2cts

Laatst gewijzigd door Buur; 22 June 2009 om 17:09.
  #16  
Oud 22 June 2009, 17:59
Buur's schermafbeelding
» iPhone 5s 32GB (Space Grijs) [FW: 8.4]  [Jailbreak: Ja]
» iPad Air Wi-Fi 16GB (Zilver) [FW: 8.4]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 26 July 2008
Locatie: /dev/null
Berichten: 667
Standaard

Citaat:
Oorspronkelijk geplaatst door FerryM Bekijk bericht
Ik kan mijn Cydia na de update niet meer vinden, iemand een idee hoe ik die terug kan krijgen? Installer , winterbord etc niet meer zichtbaar...
Hoogstwaarschijnlijk heb je Cydia (en misschien nog meerdere andere apps) verborgen tijdens je vorige jailbreak en na de 3.0upgrade+jailbreak iTunes je backup terug laten zetten, waardoor de onzichtbaarheidsinstellingen weer van kracht werden. Cydia is dus wel geinstalleerd, alleen verborgen.

Wat schijnt te helpen (heb dit zelf niet getest, daar ik WEL zo slim was om alle onzichtbare apps weer zichtbaar te maken VOORdat ik FW3.0 erop zette, da's een tip voor je volgende keer! ) is het volgende. Een oplossing die niet zo voor de hand lijkt te liggen, maar wel werkt blijkbaar:

Ga naar Instellingen > Algemeen
Automatisch slot: UIT zetten
Codeslot: UIT zetten
Beperkingen; deze inschakelen en daarna weer uitschakelen.
(Misschien moet er hierna een respring of reboot plaatsvinden, daar heb ik niks over kunnen vinden.)

Nu zou Cydia weer zichtbaar moeten zijn op je SpringBoard.
Hierna mag je je Automatische slot en pincode (Codeslot) weer inschakelen, als je dat wilt. Dat verandert niks meer aan de zichtbaarheid.

Succes! En laat even terug weten of het echt geholpen heeft? Dan kunnen anderen er weer baat bij hebben.

P.S.
M.b.t. wat je meldt dat er nog meer niet zichtbaar is:
Installer zul je niet meer vinden, die is dood en de Installer repo's na 1 juli ook. Als je perse een vervanger voor Cydia zou willen, dan is er nu Icy (repo even toevoegen aan Cydia: apt.ripdev.com of kijk onder het kopje Repositories in Cydia, nadat die alle essentiŽle updates gehad heeft). Icy werkt op de Cydia-manier en gebruikt dus ook de Cydia-repo's.
WinterBoard is nog niet helemaal compatible met FW3.0! Hou de updates in de gaten dus. De stelregel nu met de grote overgang naar 3.0 is toch wel: bezint eer ge begint! Kijk steeds onder de knop More Info wat hetgeen doet wat je wilt installeren via Cydia en of het al compatible is met FW3.0. Of kijk regelmatig op het forum. Hou rekening met heel veel incompatibiliteiten, dus installeer niet als een gek al je oude toeters en bellen!
SBSettings 3.0.1 werkt nu naar behoren met FW3.0: hier kun je de eventueel nog verborgen apps weer mee te voorschijn halen. BossPrefs werkt ook (let op dat je de laatste versie gebruikt, ik meen 3.0.2), maar die zal niet meer bijgehouden worden door BigBoss, die gaat al zijn aandacht richten op SBSettings voortaan. Beste is dus om geen BossPrefs meer te gebruiken, maar SBSettings. (Voor degenen die BossPrefs gewend zijn en nu overstappen naar SBSettings: dit is een mooi voorbeeld van waarom je altijd die More Info bij een app in Cydia moet lezen VOOR installatie! SBSettings installeert geen icoontje op je SpringBoard, zoals BossPrefs dat wel had/heeft. SBSettings activeren gaat als volgt: slide van links naar rechts over je statusbalk (de balk bovenin met tijd e.d.). En dan nog een opmerking! Niet alle SBSettings Toggles en extra's die je ervoor kunt installeren, werken nu al met FW3.0! Dus ook hier geldt: ben voorzichtig met de toeters en bellen. AutoLock SBToggle werkt voorlopig nog niet, als voorbeeldje.)

Goh, ik probeer overvolledig te zijn, geloof ik...

/EDIT:
Weer helemaal "back on topic"... Zojuist heeft Cydia alweer een update gehad van zichzelf! Denk eraan: ALTIJD installeren, nooit die Ignore-knop kiezen!

Laatst gewijzigd door Buur; 22 June 2009 om 18:39.
  #17  
Oud 22 June 2009, 20:38
Ibby's schermafbeelding
» iPhone 5 16GB (Zwart) [FW: 6.0]  [Jailbreak: Nee]
» iPad 2 Wi-Fi + 3G 16GB (Wit) [FW: 5.0.1]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 2 November 2007
Berichten: 90
Standaard

Mijn dank is groot, heel mijn iPhone is van slag...
Na de upgrade essentiele updates een vastloper in Cydia.
Nu met opstarten alleen maar een appeltje...
__________________
OTB 4.0.2 -> 4.1
  #18  
Oud 22 June 2009, 20:50
» iPhone 4 16GB (Zwart) [FW: 4.0.1]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 12 August 2008
Berichten: 14
Standaard

update van cydia werkt niet krijg couldn't configure pre-depend dpkg for ncursus, probably a dependency cycle iedere keer

iemand een idee,
  #19  
Oud 22 June 2009, 21:00
Ibby's schermafbeelding
» iPhone 5 16GB (Zwart) [FW: 6.0]  [Jailbreak: Nee]
» iPad 2 Wi-Fi + 3G 16GB (Wit) [FW: 5.0.1]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 2 November 2007
Berichten: 90
Standaard

Op Twee iPhones gedaan en beiden zijn vastgelopen!!!
Ben er nu al een van aan het herstellen.
Misschien beter om deze post eens te checken, want dit sucks
  #20  
Oud 22 June 2009, 21:30
» iPhone 4 16GB (Zwart) [FW: 4.0.1]  [Jailbreak: Ja]
» Mac OS X
 
Geregistreerd: 12 August 2008
Berichten: 14
Standaard

mijn probleem is opgelost de jailbreak eroverheen gezet, en toen niet alles geupgrade in 1 keer, maar op ignore gedrukt, en toen 1 voor 1 geupdate
Reageren

Labels
aanpassen, cydia, repo, saurik


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
Maak je eigen cydia repo! starbbs Jailbreak apps en thema's 5 6 April 2011 14:52
iPhone: Cydia Repo toevoegen spysical Jailbreak 0 27 June 2010 21:47
Cydia Updates (Changes) MichaelJ Jailbreak apps en thema's 10 17 September 2009 10:28

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 04:16.