Distributie probleem

Distributie probleem discussie in Ontwikkelen voor iOS forum; ( verdwijnt na registratie ) Dag, Ik heb mijn app af en ben al de hele middag bezig om deze met Application Loader te uploaden naar Apple maar het lukt ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > Development > Ontwikkelen voor iOS
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen

Reageren

 

Discussietools Weergave
  #1  
Oud 2 February 2011, 19:18
» iPhone 4 16GB (Wit) [FW: 4.3.3]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 8 October 2008
Berichten: 69
Standaard Distributie probleem

Dag,

Ik heb mijn app af en ben al de hele middag bezig om deze met Application Loader te uploaden naar Apple maar het lukt niet.

Ik doe het volgende:

1. In X-code: Build and Archive
2. Dan in Organizer druk ik op Validate...
3. Ik krijg dan de foutmelding: "Application Failed Codesign verification..."

Wat doe ik fout?
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 3 February 2011, 10:18
Nikooos's schermafbeelding
» iPhone 5 32GB (Zwart) [FW: 10.0.2]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 16GB (Wit) [FW: 10.0.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 28 November 2007
Locatie: Tilburg
Berichten: 3.183
Standaard

Het lijkt erop alsof je provisioning profile niet goed is ingesteld. De foutmelding wijst in ieder geval in die richting.
  #3  
Oud 3 February 2011, 10:56
» iPhone 4 32GB (Zwart) [FW: 4.3.3]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 18 November 2007
Locatie: Utrecht
Berichten: 25
Standaard

Check in je Project Settings en in de Target Settings of je Code Signing Identity correct is. Let er wel op dat je Active Configuration op "Distribution" staat.

Als je daar geen passende optie hebt, dan moet je een nog een provisioning profile aanmaken.

Wat bij mij vaak mis gaat bij die App loader is dat mijn bestandsnaam een spatie heeft of zoiets naars.
  #4  
Oud 3 February 2011, 11:18
» iPhone 4 16GB (Wit) [FW: 4.3.3]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 8 October 2008
Berichten: 69
Standaard

Ik heb inderdaad bij distributie geen passende optie. Heb die wel aangemaakt volgens mij maar komt niet in beeld. Overigens wel bij Release... Maar als ik dat dus selecteer dan heb ik een code signing probleem...

Wat een enorm ingewikkelde procedure is dit trouwens...
  #5  
Oud 3 February 2011, 20:11
» iPhone 4 32GB (Zwart) [FW: 5.0 Beta]  [Jailbreak: Nee]
» iPad 1 Wi-Fi 64GB [FW: 5.0 Beta]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 9 January 2011
Locatie: Heemstede
Berichten: 63
Standaard

Hallo,

Ik had ook veel problemen hier mee

Dit is misschien wel een goede link

Tutorial 13 - Appstore Submission on Vimeo
  #6  
Oud 3 February 2011, 21:02
» iPhone 4 16GB (Wit) [FW: 4.3.3]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 8 October 2008
Berichten: 69
Standaard

Ik heb een deel van de video nu bekeken maar ik loop vast met een maken van een Build met de distributieprofiel... Ik krijg dan de code sign error....
  #7  
Oud 3 February 2011, 21:43
» iPhone 4 16GB (Wit) [FW: 4.3.3]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 8 October 2008
Berichten: 69
Standaard

Beste Psychonikeo of iMidas,

Ik sta op het punt om mijn macbook, iphone, ipod(s) de deur uit te gooien. Wat een ellende is deze procedure... Grrrrrrrrrrrrrrrrrr.

Ik heb met succes een distributieprofiel aangemaakt. Heb mijn certificaat in de sleutelhanger hangen. Heb de configuratie als de target gecontroleerd en staan beide op dit profiel.

Toch die vervloekte Code Sign error aan het eind...

Kan 1 van jullie tweeen mij aan het handje nemen????
  #8  
Oud 3 February 2011, 22:32
» iPhone 4 32GB (Zwart) [FW: 4.3.3]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 18 November 2007
Locatie: Utrecht
Berichten: 25
Standaard

Heb jij tussentijds je project hernoemd? Dan wil nog wel ergens de oude naam staan. Gebruik binnen de Active-Target-Info en de Project-Setting windows de zoekfunctie op die oude naam en zorg dat die gelijk is aan je bundle identifier. Check ook je Info.plist op die oude naam.
  #9  
Oud 4 February 2011, 08:13
» iPhone 4 32GB (Zwart) [FW: 5.0 Beta]  [Jailbreak: Nee]
» iPad 1 Wi-Fi 64GB [FW: 5.0 Beta]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 9 January 2011
Locatie: Heemstede
Berichten: 63
Standaard

Als ik jou was zou ik een niew AppID aanmaken met een nieuw provisioning profile die dus aan elkaar koppelen dan die twee in je KeyChain zetten en vervolgens dat distribution profile koppelen aan je distribution bij configuration.
  #10  
Oud 4 February 2011, 10:37
» iPhone 4S 16GB (Wit) [FW: 5.0.1]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 64GB (Zwart) [FW: 5.0.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 30 June 2009
Berichten: 137
Send a message via twitter to Jeroen0704
Standaard

Ik heb dit probleem ook gehad. De fout zat bij mij in de certificaten uit de keychain. Dit programma vind je bij hulpprogramma's op je Mac. Hierin moet je al je developer certificaten verwijderen en dan opnieuw aanmaken, downloaden en installeren.

Of je ook nieuwe app ID's en provisioning profiles moet aanmaken weet ik niet meer zeker.
  #11  
Oud 4 February 2011, 10:53
» iPhone 4 16GB (Wit) [FW: 4.3.3]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 8 October 2008
Berichten: 69
Standaard

Dat heb ik gisteravond (nacht) inderdaad gedaan. Heb weer een nieuw certificaat gemaakt en geinstalleerd. Ik kan alleen nu helemaal geen enkele build meer maken (ook geen developer build dus)...

Ik ben echt helemaal uitgepuzzeld.
  #12  
Oud 4 February 2011, 12:08
» iPhone 4 16GB (Wit) [FW: 4.3.3]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 8 October 2008
Berichten: 69
Standaard

Het moet iets te maken hebben met mijn certificaat. Ik krijg deze log meldingen:


/Users/jpstolte/Documents/Progjes/Stop_final/build/Debug-iphoneos/Stop.app: CSSMERR_TP_NOT_TRUSTED
Command /usr/bin/codesign failed with exit code 1
  #13  
Oud 4 February 2011, 12:41
» iPhone 4S 16GB (Wit) [FW: 5.0.1]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 64GB (Zwart) [FW: 5.0.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 30 June 2009
Berichten: 137
Send a message via twitter to Jeroen0704
Standaard

Ik zou die melding eens intypen op google. Zo heb ik mijn oplossing ook gevonden.
  #14  
Oud 4 February 2011, 13:02
» iPhone 4 16GB (Wit) [FW: 4.3.3]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 8 October 2008
Berichten: 69
Standaard

misschien dat dit jullie wat zegt:

En ja, ik heb gegoogled. Maar de oplossingen die daar staan helpen niet (System Default bij het certificaat).

  #15  
Oud 4 February 2011, 13:11
» iPhone 4S 16GB (Wit) [FW: 5.0.1]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 64GB (Zwart) [FW: 5.0.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 30 June 2009
Berichten: 137
Send a message via twitter to Jeroen0704
Standaard

Heb je hem aangemaakt volgens de handleiding in het iOS Provisioning portal? Misschien moet je hem nog een keer verwijderen en opnieuw aanmaken volgens de manier van Apple?

https://developer.apple.com/ios/mana...m/howto.action
En dan alle stappen volgen. Zo heb ik het kunnen oplossen

Laatst gewijzigd door Jeroen0704; 4 February 2011 om 13:17.
  #16  
Oud 4 February 2011, 13:18
» iPhone 4 16GB (Wit) [FW: 4.3.3]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 8 October 2008
Berichten: 69
Standaard

Okay. Gedaan en nu ben ik eindelijk een stap verder. Ik heb nu een developement profiel... De app draait nu weer op mijn iPhone. Om zeker te zijn. Welke stappen moet ik nu zetten?
  #17  
Oud 4 February 2011, 13:29
» iPhone 4S 16GB (Wit) [FW: 5.0.1]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 64GB (Zwart) [FW: 5.0.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 30 June 2009
Berichten: 137
Send a message via twitter to Jeroen0704
Standaard

In itunes connect heb je een nieuwe app aan moeten maken en daar heb je als het goed is een bundle identifier moeten kiezen (zo heet het volgens mij) Dit is de bundle identifier die je ook in Xcode in je .plist moet zetten en die van je App ID. Als ik jou was zou ik een nieuw distribution profile maken. Je kiest bij deze de App ID die je ook in itunes connect hebt gebruikt. Downloaden dit profiel en sleep het naar xcode. Ga in Xcode op je project staan ctrl click erop (of rechtermuisknop) en kies "get info" ga naar de "build" tap en scroll naar "Code signing identity" Kies hier het profiel wat je hebt aangemaakt en nu zou je je app kunnen builden voor distributie. Zet "active configuration" dan wel op "release'" ipv "debug"

Succes ermee!
  #18  
Oud 4 February 2011, 14:41
» iPhone 4 16GB (Wit) [FW: 4.3.3]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 8 October 2008
Berichten: 69
Standaard

Vreemd. Ik heb nu geen private key voor de distribution profile...

  #19  
Oud 4 February 2011, 17:30
» iPhone 4 16GB (Wit) [FW: 4.3.3]  [Jailbreak: Nee]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 8 October 2008
Berichten: 69
Standaard

Yes! Het is gelukt. Dankzij jullie hulp! De app is ingediend ter beoordeling!

Dank iMidas, Jeroen0704 en Chrizzz!
  #20  
Oud 6 February 2011, 19:48
» iPhone 4S 16GB (Wit) [FW: 5.0.1]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 64GB (Zwart) [FW: 5.0.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 30 June 2009
Berichten: 137
Send a message via twitter to Jeroen0704
Standaard

Graag gedaan

Hoe heet je app eigenlijk?
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
Netwerk probleem en ander probleem Dannybevers iPhone algemeen 0 21 November 2009 00:19
Windows: Itunes probleem of Firmware 3.1 probleem ? satfreak1969 iTunes 0 22 September 2009 15:05
Tax/BTW formulier voor App Store distributie Malork Ontwikkelen voor iOS 36 17 September 2009 16:04
iTunes Wi-Fi music store probleem en sms app probleem bart2jes Wi-Fi 0 24 June 2009 22:11

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 00:31.