Camera werkt niet

Camera werkt niet discussie in Muziek, foto & video forum; ( verdwijnt na registratie ) Hey, Ik na een tijdje geleden de hele map waar alle foto's in stonden geleegd te hebben werkt de camera niet meer goed. Wanneer ik ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > Media > Muziek, foto & video
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen

Reageren

 

Discussietools Weergave
  #1  
Oud 26 May 2008, 16:54
» iPhone US 8GB [FW: 1.1.4]  [Jailbreak: Ja]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 13 February 2008
Berichten: 15
Standaard Camera werkt niet

Hey,

Ik na een tijdje geleden de hele map waar alle foto's in stonden geleegd te hebben werkt de camera niet meer goed. Wanneer ik nu een foto maak en naar Camera Roll ga krijg ik witte vierkantjes met zwarte omlijningen ipv de foto's zelf. Wnaneer ik op zo'n vierkantje druk crasht camera en ga ik naar het homescreen. Nu heb ik net de complete DCIM map van m'n broertje gekopieerd en naar mijne gezet, maar nu werkt het nog steeds niet. De foto's van hem stana er wel, maar die van mij worden gewoon weer witte vierkantjes.

Weet iemand de oplossing?

Mvg,
Ruben
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 26 May 2008, 16:58
iPhone(club) Guru
» iPhone 4S 64GB (Zwart) [FW: 5.0.1]  [Jailbreak: Ja]
» iPad 1 Wi-Fi +3G 64GB [FW: 5.0.1]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 6 December 2007
Locatie: Naarden
Berichten: 1.366
Standaard

Staan de rechten en de owner goed van de betreffend DCIM folders? Ik heb het vermoeden dat de camera geen foto's mag opslaan. De owner zou "mobile" moeten zijn en de rechten moeten op minimaal 0755 staan.
  #3  
Oud 26 May 2008, 17:03
» iPhone US 8GB [FW: 1.1.4]  [Jailbreak: Ja]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 13 February 2008
Berichten: 15
Standaard

Hm daar kan je inderdaad gelijk in hebben. Even wat screenshots bijgevoegd.

Als je de owner van 100APPLE wil veranderen krijg je die error.
Bijgevoegde afbeelding(e)
Bestandstype: png Afbeelding 1.png‎ (35,7 KB, 148x gelezen)
Bestandstype: png Afbeelding 2.png‎ (36,1 KB, 78x gelezen)
Bestandstype: png Afbeelding 3.png‎ (24,2 KB, 67x gelezen)
  #4  
Oud 26 May 2008, 17:42
iPhone(club) Guru
» iPhone 4S 64GB (Zwart) [FW: 5.0.1]  [Jailbreak: Ja]
» iPad 1 Wi-Fi +3G 64GB [FW: 5.0.1]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 6 December 2007
Locatie: Naarden
Berichten: 1.366
Standaard

Zet de rechten eens op 777 (dan is de owner namelijk niet meer van belang).
De owner kun je met onderstaand commando veranderen. Ik heb de owner nog nooit geprobeerd te veranderen met Fugu, maar de group van mobile is ook mobile, misschien werkt het wel als je deze ook wijzigd.

Code:
chown mobile:mobile -R /private/var/mobile/Media/DCIM
  #5  
Oud 26 May 2008, 17:47
» iPhone US 8GB [FW: 1.1.4]  [Jailbreak: Ja]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 13 February 2008
Berichten: 15
Standaard

Wooo! Hij werkt! Echt geweldig, heel erg bedankt.

Is er nou eigenlijk een snelle manier alle foto's in 1x te verwijderen?
  #6  
Oud 3 July 2008, 22:01
» iPhone NL 8GB
» Windows
 
Geregistreerd: 3 July 2008
Berichten: 5
Standaard

Wat ruben hierboven zegt is sinds gister bij mij ook het geval ..

Echt super Ruben dat hij bij jou weer werkt .. maar ik snap niet goed wat owner enz is .. zou je mij stap voor stap uit kunnen leggen hoe ik het kan oplossen ..

Ik ga zaterdag met vakantie en zou super graag mooie foto's willen maken

Groetjes een hopeloos meisje
  #7  
Oud 3 July 2008, 22:06
» iPhone NL 8GB
» Windows
 
Geregistreerd: 3 July 2008
Berichten: 5
Standaard

Beste ,

Iedereen die mij op dit moment met hetzelfde probleem als wat ruben hierboven omschrijft kan helpen draag ik op handen ..

Jullie leggen het voor mij als dame te moeilijk uit haha

where do I start ?
  #8  
Oud 3 July 2008, 22:38
» iPhone US 8GB [FW: 1.1.4]  [Jailbreak: Ja]
» Ik heb geen iPad  
» Mac OS X
 
Geregistreerd: 13 February 2008
Berichten: 15
Standaard

Gebruik je Windows of Mac OSX?


Misschien kan ik je helpen via msn? ruben- [at] live [dot] .com
  #9  
Oud 3 July 2008, 22:41
» iPhone NL 8GB
» Windows
 
Geregistreerd: 3 July 2008
Berichten: 5
Standaard

ruben-@live.
  #10  
Oud 4 July 2008, 11:18
» iPhone NL 8GB
» Windows
 
Geregistreerd: 3 July 2008
Berichten: 5
Standaard

Wat moet je doen als je met Windows op je computer werkt en je hebt geen Wi-fi verbinding thuis ..
  #11  
Oud 4 July 2008, 14:56
iPhone(club) Guru
» iPhone 4S 64GB (Zwart) [FW: 5.0.1]  [Jailbreak: Ja]
» iPad 1 Wi-Fi +3G 64GB [FW: 5.0.1]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 6 December 2007
Locatie: Naarden
Berichten: 1.366
Standaard

Je kunt ook FileBrowser op je iPhone installeren (staat in de iSpazio repo).
Dan kun je op je iPhone gewoon de rechten zetten.

- Open FileBrowser
- Druk net zo lang up "Up" totdat je in de root zit (je ziet "/" als folder boven in het scherm)
- Ga dan naar private/var/mobile/Media
- Druk op "Tools"
- Druk op "Properties"
- Selecteer de folder DCIM
- zet de "Permissions" op 777
- "Set recurively" moet aan staan
- Druk op "Save"

Door de rechten op 777 te zetten is de "owner" niet meer van belang.
Dit zou moeten werken.

Suc6.

Laatst gewijzigd door ControlSje; 4 July 2008 om 14:59.
  #12  
Oud 4 July 2008, 23:30
» iPhone 4 16GB (Zwart) [FW: 4.0.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 24 December 2007
Berichten: 3
Standaard

Helaas, bij mij werkt 777-truck van ControlSje niet.
Ook na herstarten iPhone nog witte thumbs en crash bij openen foto's.

Andere suggesties?
  #13  
Oud 4 July 2008, 23:37
» iPhone NL 8GB
» Windows
 
Geregistreerd: 3 July 2008
Berichten: 5
Standaard

ik snap precies wat Yolanda bedoelt ..


Ik ga morgen op vakantie en heb de hulp van Stef nog niet eens kunnen uitvoeren omdat ik vastloop al bij de eerste
  #14  
Oud 23 August 2008, 17:33
» iPhone US 8GB [FW: 2.0]
» Windows
 
Geregistreerd: 15 November 2007
Berichten: 5
Standaard

Ik heb dit probleem ook. Hoe kan ik de rechten van de directory aanpassen in versie 2.0.1?
  #15  
Oud 24 August 2008, 02:08
» iPhone NL 8GB [FW: 2.2]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 19 May 2008
Berichten: 4
Standaard

Geen idee of het bij iedereen werkt, maar ik heb de problemen met het foto's maken met mijn Iphone opgelost. Denk ik
Na het installeren van een ander fotoprogramma (in mijn geval Snapture) en het nemen van een foto daarmee, bleek de 'filmrol' ineens weer normaal gevuld te worden.
Inmiddels had ik WINSCP op mijn PC genstalleerd. Na wat stoeien met de bestanden bleek dat het bestand \private\var\mobile\media\dcim\.misc\info.plist een aantal regels bevatte, die verwezen naar de diverse directories onder DCIM, met ook nog een tellertje per directorie. Na eerst dat bestandje gecopieerd te hebben naar mijn pc heb ik het gewoon uit de MISC directory weggemikt. Ook de 100APPLE, 101APPLE enz directories heb ik volledig verwijderd. Bij het nemen van de eerste foto met de normale Camera applicatie werd er netjes een foto in de filmrol geplaatst, met het goede volgnummer.
Ik vermoed dat het info.plist bestand mogelijk de boosdoener is geweest in het hele verhaal.
Kortom: de MISC directorie leegmaken, en de 1xxAPPLE directories weggooien, en alles lijkt weer te werken.
  #16  
Oud 24 August 2008, 22:44
» iPhone US 8GB [FW: 2.0]
» Windows
 
Geregistreerd: 15 November 2007
Berichten: 5
Standaard

Ik heb het anders opgelost. In mijn geval was de oorzaak verkeerde rechten in de media directory. Dit kun je oplossen door BossPrefs te installeren en dan de optie (bij More) Fix User Dir Permissions te selecteren in de BossPrefs applicatie.

Succes voor degene die dit probleem ook hebben.
  #17  
Oud 16 February 2009, 20:39
» iPhone US 8GB [FW: 1.1.1]  [Jailbreak: Nee]
» Windows
 
Geregistreerd: 23 October 2007
Berichten: 9
Standaard

Hallo,

Ik heb helaas hetzelfde probleem met mijn iphone sinds kort. Foto's die niet opgeslagen worden.
Echter heb ik geprobeerd de adviesen op te volgen die hierboven staan maar het lukt mij niet om een programmatje te downloaden enzo.
Is er iemand die mij simpel kan uitleggen wat te doen?

Mag evt ook naar ferryboers@hotmail.com

Hoor graag van iemand!
  #18  
Oud 28 February 2009, 15:20
» iPhone 3G 16GB (Zwart) [FW: 2.2.1]  [Jailbreak: Ja]
» Windows
 
Geregistreerd: 18 February 2009
Berichten: 1
Standaard

Citaat:
Oorspronkelijk geplaatst door ferryboers Bekijk bericht
Hallo,

Ik heb helaas hetzelfde probleem met mijn iphone sinds kort. Foto's die niet opgeslagen worden.
Echter heb ik geprobeerd de adviesen op te volgen die hierboven staan maar het lukt mij niet om een programmatje te downloaden enzo.
Is er iemand die mij simpel kan uitleggen wat te doen?

Mag evt ook naar ferryboers@hotmail.com

Hoor graag van iemand!
Had tot net hetzelfde probleem.
Ik heb het via bossprefs gedaan zoals victor97 zei (ik dank u!!).
Werkte perfect!

Uitleg:
Neem aan dat je je iphone gejailbreaked hebt. (anders moet je dit namelijk doen, zie ergens anders op dit forum).

Start dan Cydia op
zoek op "bossPrefs" en installeren
dan bossprefs openen en op "more" klikken (rechter boven hoek)
dan op "Fix User dir Permissions" klikken en accepteren.
  #19  
Oud 16 October 2009, 14:55
Mootjuh's schermafbeelding
» iPhone 3GS 16GB (Zwart) [FW: 4.0.1]  [Jailbreak: Ja]
» Ik heb geen iPad  
» Windows
 
Geregistreerd: 11 September 2009
Locatie: Nijkerk
Berichten: 189
Stuur een bericht via MSN naar Mootjuh Send a message via twitter to Mootjuh
Standaard

Citaat:
Oorspronkelijk geplaatst door stimpyrules Bekijk bericht
Had tot net hetzelfde probleem.
Ik heb het via bossprefs gedaan zoals victor97 zei (ik dank u!!).
Werkte perfect!

Uitleg:
Neem aan dat je je iphone gejailbreaked hebt. (anders moet je dit namelijk doen, zie ergens anders op dit forum).

Start dan Cydia op
zoek op "bossPrefs" en installeren
dan bossprefs openen en op "more" klikken (rechter boven hoek)
dan op "Fix User dir Permissions" klikken en accepteren.
Dit lukt bij mij dus niet, ook na een reboot gaat het nog steeds niet, ik krijg geen KLIK te horen als ik een foto maak en komt dan dus ook niet in me filmrol terecht... iemand nog suggesties?? ps.. ik ben een leek in Iphone wereld.. dus graag in jip en janneke taal....
__________________
Happy met me Iphone..!!!
  #20  
Oud 18 October 2009, 03:39
» iPhone 5 16GB (Wit) [FW: 8.3]  [Jailbreak: Nee]
» iPad Air Wi-Fi 128GB (Spacegrijs) [FW: 8.3]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 20 November 2007
Locatie: Barendrecht
Berichten: 60
Standaard

@Mootjuh

Download iFile uit Cydia, start de app op en ga naar /private/var/mobile/media/dcim.
Klik op de rechterpijltje en scroll op vervolgpagina naar ownership. Wijzig hier Owner in "mobile" en Group ook in "mobile". iFile afsluiten en dan moet ie het doen.

Wat je ook kan doen is je Apple100 directory in /private/var/mobile/media/dcim verwijderen en en vervolgens een nieuwe foto maken. De iPhone zal dan ook meteen een nieuwe directory aanmaken voor het opslaan van je fot's.
suc6.
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
Foto: Mijn camera werkt niet. stoare Muziek, foto & video 3 18 February 2011 12:22
Camera werkt niet jose9 iPhone algemeen 5 2 April 2010 20:36
Camera werkt niet meer Mootjuh Archief 2 15 October 2009 21:40
Camera werkt niet meer dirkkes iPhone algemeen 3 14 April 2009 12:38
Camera en Photos werkt niet SuppleX Unlock [archief] 3 9 April 2008 14:53

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 03:25.