XCode signing fout

XCode signing fout discussie in Ontwikkelen voor iOS forum; ( verdwijnt na registratie ) Hoi, Ik probeer mijn app te builden voor distributie, maar ik krijg helaas een error. CodeSign error: a valid provisioning profile is required for product ...



Ga terug   iPhone, iPod touch, iPad en Apple TV forum > Development > Ontwikkelen voor iOS
Wachtwoord vergeten? Registreren!
Registreer FAQ Ledenlijst Kalender Zoeken Berichten van vandaag Markeer forums als gelezen
  #1  
Oud 20 March 2009, 16:14
iGregor's schermafbeelding
» iPhone 4 16GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 32GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 9 August 2008
Locatie: Zutphen
Berichten: 132
Stuur een bericht via MSN naar iGregor
Standaard XCode signing fout

Hoi,

Ik probeer mijn app te builden voor distributie, maar ik krijg helaas een error.

CodeSign error: a valid provisioning profile is required for product type 'Application' in SDK 'Device - iPhone OS 2.2'


Mijn provisioning profile is helemaal goed, en ik heb hem ook goed ingesteld volgens mij. Ik gebruik phonegap (PhoneGap | Cross platform mobile framework) en volgens hun is dit het: iPhone SDK 2.2 - CodeSign Error | furmanek.net

Ik snap alleen niet hoe ik het moet doen e.d.

Kan iemand mij toevallig helpen?

Alvast bedankt,

Gregor Biljardt
__________________
Werkzaam bij MediaWaaier in Zutphen. Ontwikkeling van iPhone, iPad (en eventueel ook Android) apps.
Advertentie
Advertentie Gesponsorde links (verdwijnt na registratie)

  #2  
Oud 21 March 2009, 08:39
macfreaker's schermafbeelding
iPhone(club) Guru
» iPhone 5s 32GB (Space Grijs) [FW: 9.2]  [Jailbreak: Nee]
» iPad Pro 10,5 Wi-Fi 256GB (Zilver) [FW: 11.1]  [Jailbreak: Nee]
» OS X
 
Geregistreerd: 16 December 2007
Locatie: Aalst(50.936242,4.025867)
Berichten: 2.186
Stuur een bericht via ICQ naar macfreaker Stuur een bericht via Instant Messenger naar macfreaker Stuur een bericht via MSN naar macfreaker Stuur een bericht via Skype™ naar macfreaker
Standaard

Heb eens gekeken naar phonegap en het voorbeeld bestand geprobeerd en deze werkt perfect in debug. Echter in release of distribution krijg ik een ook fout maar heeft niets te maken met provsioning maar iets anders wat ik nog niet vind. Ik zou zeggen nogmaals je bestandje opnieuw(provisioning) inzetten.
  #3  
Oud 21 March 2009, 09:34
iGregor's schermafbeelding
» iPhone 4 16GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 32GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 9 August 2008
Locatie: Zutphen
Berichten: 132
Stuur een bericht via MSN naar iGregor
Standaard

Citaat:
Oorspronkelijk geplaatst door macfreaker Bekijk bericht
Heb eens gekeken naar phonegap en het voorbeeld bestand geprobeerd en deze werkt perfect in debug. Echter in release of distribution krijg ik een ook fout maar heeft niets te maken met provsioning maar iets anders wat ik nog niet vind. Ik zou zeggen nogmaals je bestandje opnieuw(provisioning) inzetten.
Bedankt voor je antwoord, maar helaas had ik dat al geprobeerd...
Ik kan het niet vinden...
Release lukt bij mij wel, maar distribution niet...
Ik heb de correcte provisioning erin gedaan, maar het lukt gewoon niet.
  #4  
Oud 21 March 2009, 11:39
Malork's schermafbeelding
» iPhone 4S 32GB (Wit) [FW: 5.1.1]  [Jailbreak: Nee]
» iPad 3 Wi-Fi + 4G 16GB (Zwart) [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 31 May 2008
Locatie: Landgraaf
Berichten: 178
Stuur een bericht via MSN naar Malork
Standaard

Misschien vertel ik dingen die je al weet, maar dit is hoe ik het doe:

Je distribution provisioning profile is anders dan die van het debuggen / developen. Ikzelf heb 3 provisioning profiles: een voor develop / debug, een voor adhoc-distributie en een voor App store distributie.

in de iPhone SDK zet je moet de target selecteren, dan info, dan tabblad 'build'.
bij "code signing identity" selecteer je je distribution provisioning file.
Daarna klik je op je project, voeg je een 'nieuw file' toe en dat is een Entitlements.plist bestand. Daarna selecteer je je project, Info, tabblad "Build" en bij 'Code Signing entitlements' tiep je "entitlements.plist".
Zorg er wel voor dat je het juiste profiel selecteert (debug/release/distribution).

Wat ZEKER helpt is om op de iPhone developer site de stapsgewijze tutorial te volgen over hoe je een distributie-build maakt voor zowel AdHoc als Appstore. Deze heb ik ook gevolgd en kan het nu bijna blindelings (maak wel eens een foutje ). Heb ook al succesvol AdHoc builds gemaakt.
  #5  
Oud 21 March 2009, 11:39
macfreaker's schermafbeelding
iPhone(club) Guru
» iPhone 5s 32GB (Space Grijs) [FW: 9.2]  [Jailbreak: Nee]
» iPad Pro 10,5 Wi-Fi 256GB (Zilver) [FW: 11.1]  [Jailbreak: Nee]
» OS X
 
Geregistreerd: 16 December 2007
Locatie: Aalst(50.936242,4.025867)
Berichten: 2.186
Stuur een bericht via ICQ naar macfreaker Stuur een bericht via Instant Messenger naar macfreaker Stuur een bericht via MSN naar macfreaker Stuur een bericht via Skype™ naar macfreaker
Standaard

Citaat:
Oorspronkelijk geplaatst door gregor Bekijk bericht
Bedankt voor je antwoord, maar helaas had ik dat al geprobeerd...
Ik kan het niet vinden...
Release lukt bij mij wel, maar distribution niet...
Ik heb de correcte provisioning erin gedaan, maar het lukt gewoon niet.
Werk je je met de laatste sdk (3.1) ? Daar had ideveloper ook iets over geschreven in een andere post. Misschien eens even zoeken en kijken wat die had. Alhoewel ik ook van sdk ben veranderd en bij mij alles feilloos werkt. Het proleem met phonegap is ook opgelost door een bestand te hernoemen. Kan dus zowel in debug, release als distribution werken .
  #6  
Oud 21 March 2009, 13:44
iGregor's schermafbeelding
» iPhone 4 16GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 32GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 9 August 2008
Locatie: Zutphen
Berichten: 132
Stuur een bericht via MSN naar iGregor
Standaard

Ik werk inderdaad met 3.1.2
@Malork, dat weet ik inderdaad, ik heb een dev & app store provisioning. De app store provisioning heb ik er nu ingestopt.
  #7  
Oud 21 March 2009, 13:46
Malork's schermafbeelding
» iPhone 4S 32GB (Wit) [FW: 5.1.1]  [Jailbreak: Nee]
» iPad 3 Wi-Fi + 4G 16GB (Zwart) [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 31 May 2008
Locatie: Landgraaf
Berichten: 178
Stuur een bericht via MSN naar Malork
Standaard

aha.. er stond ook bij de SDK op de developer-site dat deze sdk NIET gebruikt kan worden voor distributie van Apps voor 2.x. wellicht dat dat dan inderdaad het probleem is.
  #8  
Oud 21 March 2009, 13:56
iGregor's schermafbeelding
» iPhone 4 16GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 32GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 9 August 2008
Locatie: Zutphen
Berichten: 132
Stuur een bericht via MSN naar iGregor
Standaard

Oke, enig idee hoe ik het nu moet gaan doen dan?
  #9  
Oud 21 March 2009, 19:54
iGregor's schermafbeelding
» iPhone 4 16GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 32GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 9 August 2008
Locatie: Zutphen
Berichten: 132
Stuur een bericht via MSN naar iGregor
Standaard

Is het mogelijk de nieuwe sdk te gebruiken om voor 2.2. te developen?
  #10  
Oud 21 March 2009, 20:07
macfreaker's schermafbeelding
iPhone(club) Guru
» iPhone 5s 32GB (Space Grijs) [FW: 9.2]  [Jailbreak: Nee]
» iPad Pro 10,5 Wi-Fi 256GB (Zilver) [FW: 11.1]  [Jailbreak: Nee]
» OS X
 
Geregistreerd: 16 December 2007
Locatie: Aalst(50.936242,4.025867)
Berichten: 2.186
Stuur een bericht via ICQ naar macfreaker Stuur een bericht via Instant Messenger naar macfreaker Stuur een bericht via MSN naar macfreaker Stuur een bericht via Skype™ naar macfreaker
Standaard

Citaat:
Oorspronkelijk geplaatst door gregor Bekijk bericht
Is het mogelijk de nieuwe sdk te gebruiken om voor 2.2. te developen?
Ja, je kan kiezen voor welke versie je wilt coden. Dit kan je doen in in je project settings .
  #11  
Oud 21 March 2009, 20:49
iGregor's schermafbeelding
» iPhone 4 16GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 32GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 9 August 2008
Locatie: Zutphen
Berichten: 132
Stuur een bericht via MSN naar iGregor
Standaard

Nee, ik heb het over wat Malork over had.
  #12  
Oud 22 March 2009, 01:36
Malork's schermafbeelding
» iPhone 4S 32GB (Wit) [FW: 5.1.1]  [Jailbreak: Nee]
» iPad 3 Wi-Fi + 4G 16GB (Zwart) [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 31 May 2008
Locatie: Landgraaf
Berichten: 178
Stuur een bericht via MSN naar Malork
Standaard

voor zover ik weet ontwikkelen wel; doe ik namelijk ook. Heb op mijn MacBook de 3.0 SDK staan en op mijn iMac de 2.2.1 SDK.

Dit staat er ook bij de OS 3.0 informatie op de developer-site:

Citaat:
iPhone SDK for iPhone OS 3.0 beta is for development use only. This new version should only be deployed on devices dedicated for iPhone OS 3.0 beta software development and cannot be used for submitting iPhone OS 2.2.1 applications.
  #13  
Oud 22 March 2009, 08:26
iGregor's schermafbeelding
» iPhone 4 16GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 32GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 9 August 2008
Locatie: Zutphen
Berichten: 132
Stuur een bericht via MSN naar iGregor
Standaard

Iemand een andere oplossing dan?
  #14  
Oud 22 March 2009, 10:08
Malork's schermafbeelding
» iPhone 4S 32GB (Wit) [FW: 5.1.1]  [Jailbreak: Nee]
» iPad 3 Wi-Fi + 4G 16GB (Zwart) [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 31 May 2008
Locatie: Landgraaf
Berichten: 178
Stuur een bericht via MSN naar Malork
Standaard

Citaat:
Oorspronkelijk geplaatst door gregor Bekijk bericht
Iemand een andere oplossing dan?

de 'oude' SDK erop zetten

Als je trouwens een project maakt in SDK 3.1 en je leest hem daarna in de 2.2 SDK dan krijg je een 'SDK 3.0' melding te zien en moet je via info de huidige SDK wijzigen. Via project setting kun je alleen Mac OS X kiezen op dat moment.
  #15  
Oud 22 March 2009, 10:26
iGregor's schermafbeelding
» iPhone 4 16GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» iPad 2 Wi-Fi 32GB (Zwart) [FW: 6.0.2]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 9 August 2008
Locatie: Zutphen
Berichten: 132
Stuur een bericht via MSN naar iGregor
Standaard

Gevonden!

Het werkt

Bedankt Malork & Macfreaker
  #16  
Oud 22 March 2009, 17:37
Malork's schermafbeelding
» iPhone 4S 32GB (Wit) [FW: 5.1.1]  [Jailbreak: Nee]
» iPad 3 Wi-Fi + 4G 16GB (Zwart) [FW: 5.1.1]  [Jailbreak: Nee]
» Mac OS X
 
Geregistreerd: 31 May 2008
Locatie: Landgraaf
Berichten: 178
Stuur een bericht via MSN naar Malork
Standaard

no problem
Reageren


Er zijn 1 actieve gebruikers die momenteel deze discussie bekijken (0 leden en 1 gasten)

 
Discussietools
Weergave

Soortgelijke discussies

Discussie Auteur Forum Reacties Laatste bericht
xcode voor windows xxdenxx Ontwikkelen voor iOS 17 9 March 2013 14:13
Xcode 4 Build Failed Jeroen0704 Ontwikkelen voor iOS 4 27 September 2011 10:50
xcode iPad 2 vraag vincent.bosch Ontwikkelen voor iOS 8 5 April 2011 13:17
SDK xcode traning marcelkraan Ontwikkelen voor iOS 8 29 June 2010 11:50
Apple stopped signing 3.1.2 today Liki Chat en geruchten 0 4 February 2010 12:24

Regels voor berichten
Je mag geen nieuwe discussies starten
Je mag niet reageren op berichten
Je mag geen bijlagen versturen
Je mag niet je berichten bewerken

BB code is Aan
Smileys zijn Aan
[IMG]-code is Aan
HTML-code is Uit
Trackbacks are Aan
Pingbacks are Aan
Refbacks are Uit



Alle tijden zijn GMT +2. Het is nu 12:49.